View Issue Details

IDProjectCategoryView StatusLast Update
0003525OpenFOAMBugpublic2020-07-29 15:03
ReportergfilipAssigned Tochris 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version18.04
Product Version8 
Fixed in Version 
Summary0003525: Docker script for openfoam-8 fails to launch with permission denied problem
DescriptionI followed the docker instructions and when trying to launch openfoam-8, I get a permission denied error after the image is downloaded:

-------------------------------------------------------------------
Launching /usr/bin/openfoam8-linux
User: "gfilip" (ID 1001, group ID 1001)
/bin/sh: 1: /entry.sh: Permission denied
-------------------------------------------------------------------

I noticed that this was an issue with the image for openfoam-7 and 5 as reported on this issue tracker, so I suspect it may be the same problem that has to be resolved on the image side of things. I've tried to delete and re-download the image several times but the issue persists.
Steps To ReproduceDownload the official docker script and execute per instructions:

sudo sh -c "wget http://dl.openfoam.org/docker/openfoam8-linux -O /usr/bin/openfoam8-linux"
sudo chmod 755 /usr/bin/openfoam8-linux
openfoam8-linux

TagsNo tags attached.

Relationships

related to 0003041 closedchris "/entry.sh" within the Docker container "openfoam/openfoam6-paraview54" has the wrong permissions 
has duplicate 0003526 closedwyldckat Docker - entry.sh: Permission denied 

Activities

wyldckat

2020-07-29 11:16

updater   ~0011439

@Chris: As indicated in the description, this issue seems to be the same as reported on https://bugs.openfoam.org/view.php?id=3041 - namely the permissions might still be set to:

   -rwxr-x--- 1 root root 2769 Jul 8 15:50 /entry.sh

namely no one other than root can run the script :(

chris

2020-07-29 14:47

manager   ~0011440

Updating container...

chris

2020-07-29 15:03

manager   ~0011441

Thanks for reporting the issue. The container is updated with correct permissions on "*.sh" script files.
If there are any further problems, please let us know.

Issue History

Date Modified Username Field Change
2020-07-28 12:17 gfilip New Issue
2020-07-29 11:12 wyldckat Relationship added has duplicate 0003526
2020-07-29 11:14 wyldckat Relationship added related to 0003041
2020-07-29 11:14 wyldckat Assigned To => chris
2020-07-29 11:14 wyldckat Status new => assigned
2020-07-29 11:16 wyldckat Note Added: 0011439
2020-07-29 14:47 chris Note Added: 0011440
2020-07-29 15:03 chris Status assigned => resolved
2020-07-29 15:03 chris Resolution open => fixed
2020-07-29 15:03 chris Note Added: 0011441