View Issue Details

IDProjectCategoryView StatusLast Update
0003041OpenFOAM[All Projects] Bugpublic2018-08-23 10:37
ReporterwyldckatAssigned Tochris 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version16.04
Product Version6 
Fixed in Version 
Summary0003041: "/entry.sh" within the Docker container "openfoam/openfoam6-paraview54" has the wrong permissions
DescriptionWhile trying to diagnose the issues in report #3033, I was not able to run the container with my normal user+group IDs. I had to modify the script "openfoam6-linux" to use the root IDs for both, so that the container would launch (although changing my group ID in this script to 0 is also enough).

In other words, if I launch the original script, the error message at the end is:

  /bin/sh: 1: /entry.sh: Permission denied

This is because the permissions are set to:

  -rwxr-x--- 1 root root 2769 Jul 8 15:50 /entry.sh

Hence if my group ID is not at least 0, then this script will not run.


Removing the image with "docker rmi" and then running the script again gives me:

  Digest: sha256:17d416b459bef25374d3dcaaac4836b3351ee1c89b38ad4e48df70a5d821f890

Additional InformationThe containers for "openfoam/openfoam5-paraview54" and "openfoam/openfoam-dev-paraview54" does not have this permissions issue for this "/entry.sh" file.
TagsNo tags attached.

Activities

chris

2018-08-23 10:37

manager   ~0009993

Fixed

chris

2018-08-23 10:37

manager   ~0009994

Issue resolved with new build
https://hub.docker.com/r/openfoam/openfoam6-paraview54/

Issue History

Date Modified Username Field Change
2018-08-11 14:24 wyldckat New Issue
2018-08-11 14:24 wyldckat Status new => assigned
2018-08-11 14:24 wyldckat Assigned To => chris
2018-08-23 10:37 chris Note Added: 0009993
2018-08-23 10:37 chris Status assigned => closed
2018-08-23 10:37 chris Resolution open => fixed
2018-08-23 10:37 chris Note Added: 0009994