View Issue Details

IDProjectCategoryView StatusLast Update
0003517OpenFOAMBugpublic2020-07-14 14:40
Reporterpappo1890Assigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Versiondev 
Fixed in Version 
Summary0003517: How the momentum source term due to droplet evaporation is calculated?
DescriptionDear OpenFOAM support. This is a question I would like to ask you, rather than a bug.

The momentum source terms due to the dispersed phase can be identified as those due to the mass transfer and the forces acting on the particle. In literature, this term is expressed as in the figure in the attachment (Experiments and Numerical Simulations of Diluted Spray Combustion, B. Merci, D. Roekaerts, A. Saidiki., p.17)

I would like to have feedback about this expression and the one is used in OpenFOAM.

In OpenFOAM the momentum source term is written in the [B]UEqn.H [/B]as parcels.SU(U).
SU(volVectorField& u) const is defined in line 563 of ~/OpenFOAM2.4.0/src/lagrangianba/intermediate/clouds/Templates/KinematicCloud/KinematicCloudI.H:

[CODE]tmp<fvVectorMatrix> tfvm(new fvVectorMatrix(U, dimForce));
fvVectorMatrix& fvm = tfvm();

fvm.source() = -UTrans()/(this->db().time().deltaT());

return tfvm;
[/CODE]

[B]UTrans()[/B] is updated twice when solving the lagrangian libraries. First in the KinematicCloud, for the momentum spray source term due to the force acting on the particle and later in parcels/Templates/ReactingParcel/ReactingParcel.C (line 689):

[CODE]td.cloud().UTrans()[cellI] += dm*U0;[/CODE]

[B]U0[/B] is (line 579):
        [CODE]const vector& U0 = this->U_;[/CODE]
and at line 731 the this-> U_ pointer is calculated as the particle velocity.

The expression does not completely look like that found in literature, where the difference between the carrier and the particle velocity is considered. Could, please someone double-check if my reading of the following lines of code is correct?

Thanks in advance for your help
TagsNo tags attached.

Activities

pappo1890

2020-07-07 10:17

reporter  

momsource.JPG (13,480 bytes)
momsource.JPG (13,480 bytes)

will

2020-07-14 14:40

manager   ~0011423

Last edited: 2020-07-14 14:40

View 2 revisions

We do not provide free support or advice via this system. See https://bugs.openfoam.org/rules.php

Issue History

Date Modified Username Field Change
2020-07-07 10:17 pappo1890 New Issue
2020-07-07 10:17 pappo1890 File Added: momsource.JPG
2020-07-14 14:40 will Assigned To => will
2020-07-14 14:40 will Status new => closed
2020-07-14 14:40 will Resolution open => no change required
2020-07-14 14:40 will Note Added: 0011423
2020-07-14 14:40 will Note Edited: 0011423 View Revisions