View Issue Details

IDProjectCategoryView StatusLast Update
0003375OpenFOAMBugpublic2019-10-24 11:47
Reporterrmn_990Assigned Towill 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionsuspended 
Product Version 
Fixed in Version 
Summary0003375: Number of Trapped Particles in Different Courant Number
DescriptionHi,
I am using MPPICFoam to simulation particulate flow inside a cylinder. The strange thing that happens is that as long as I decrease maxCo in my simulation, the number of trapped particles on cylinder wall ( with stick BC) will decrease.
I expected that the number of trapped particles converges as I decrease the maxCo but this is not happening.

I also used injectionChannel tutorial case to see if the problem is regarding my simulation or not. I realized that we have the same problem with this case too.

This happens while I am sure that fluid flow converges earlier and the fluid flow is converged in these simulations.

It would be highly appreciated if you let me know what's the reason for having this difference in particle fate in different time steps.

TagsNo tags attached.

Activities

wyldckat

2019-10-24 10:23

updater   ~0010849

Quoting from the section "Reporting an Issue" at the rules page: https://bugs.openfoam.org/rules.php

    We can only resolve an issue if we can understand and reproduce it.

You are only describing a very vague symptom, without providing an example of what exactly have you done in defined values, nor did you provide a test case that shows this happening.

My guess is that you first simulated with maxCo of 10, then 5, then 1 and were expecting the same results, which would reveal that you are not familiar with what the Courant number is actually pointing out.

Furthermore, please keep in mind from the rules page:

    This site does not provide free support for the use of OpenFOAM.

So, please, provide proper details of what exactly you are doing, so that if it is a bug, it can be fixed.

will

2019-10-24 11:47

manager   ~0010850

This report does not identify a bug. Differences in simulation behaviour are to be expected with varying CFL, and this report does not identify in what way the identified differences are unreasonable or incorrect. Closing.

Issue History

Date Modified Username Field Change
2019-10-23 20:08 rmn_990 New Issue
2019-10-24 10:23 wyldckat Note Added: 0010849
2019-10-24 11:47 will Assigned To => will
2019-10-24 11:47 will Status new => closed
2019-10-24 11:47 will Resolution open => suspended
2019-10-24 11:47 will Note Added: 0010850