View Issue Details

IDProjectCategoryView StatusLast Update
0003195OpenFOAMBugpublic2019-03-15 15:20
ReporterhannesAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
PlatformOSUbuntuOS Version18.04
Product Version6 
Fixed in Version 
Summary0003195: ambient pressure drifts in interPhaseChangeDyMFoam
DescriptionIn a simulation with interPhaseChangeDyMFoam (ship hull + rotating propeller), the ambient pressure drifts up or down and violates the boundary condition prescribed at the outlet.
This leads to suppression of cavitation or excessive cavitation, depending on the direction of drift.
Steps To ReproduceUnpack attached minimum example
run with interFoam => no problems
run with interPhaseChangeDyMFoam => ambient pressure upstream from inlet increases (within ca. 0.01s)
TagsNo tags attached.

Relationships

has duplicate 0003194 closedwyldckat Ambient Pressure Drifts in interPhaseChangeDyMFoam 

Activities

hannes

2019-03-13 10:06

reporter  

MWE2.tar.xz (1,787,808 bytes)

henry

2019-03-13 10:17

manager   ~0010367

This is likely to be due to the well know continuity issues with the current AMI implementation. AMI will need to be rewritten to resolve this.

hannes

2019-03-13 10:21

reporter   ~0010368

Is there anything I can do to reduce the influence of this continuity issue? Mesh resolution on the AMI, solver tolerances or similar?

henry

2019-03-13 11:23

manager   ~0010371

The better the mesh around the AMI the better the match and the better continuity error.

hannes

2019-03-15 15:00

reporter   ~0010377

I tried to improve the mesh on the AMI but that did not seem to have an effect.

What I also did: I added the MRF object to the interPhaseChangeFoam solver and replaced the rotating mesh with a stationary zone. Thus there was no AMI present any more.

Unfortunately I have observed the same pressure drift as before.

hannes

2019-03-15 15:02

reporter   ~0010378

Here is the modified solver

interPhaseChangeDyMFoam_modified.tgz (4,856 bytes)

hannes

2019-03-15 15:05

reporter   ~0010379

The modified case was too big for upload. You can find it here: https://silentdynamics.de/MWE_MRF_noAMI.tar.xz

henry

2019-03-15 15:20

manager   ~0010380

User support request for large complex case which will require funding to work on.

Issue History

Date Modified Username Field Change
2019-03-13 10:06 hannes New Issue
2019-03-13 10:06 hannes File Added: MWE2.tar.xz
2019-03-13 10:17 henry Note Added: 0010367
2019-03-13 10:21 hannes Note Added: 0010368
2019-03-13 11:03 wyldckat Relationship added has duplicate 0003194
2019-03-13 11:23 henry Note Added: 0010371
2019-03-15 15:00 hannes Note Added: 0010377
2019-03-15 15:02 hannes File Added: interPhaseChangeDyMFoam_modified.tgz
2019-03-15 15:02 hannes Note Added: 0010378
2019-03-15 15:05 hannes Note Added: 0010379
2019-03-15 15:20 henry Assigned To => henry
2019-03-15 15:20 henry Status new => closed
2019-03-15 15:20 henry Resolution open => suspended
2019-03-15 15:20 henry Note Added: 0010380