View Issue Details

IDProjectCategoryView StatusLast Update
0003165OpenFOAMBugpublic2019-02-12 14:37
ReporterHTauberAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version16.04
Product Versiondev 
Fixed in Version 
Summary0003165: MPPICFoam: Problems with packing model "explicit" together with damping modell "relaxation"
DescriptionI used the case MPPICFoam/column and changed the packing model to "explicit", the damping model to "relaxation" and particleForce to "gravity". The particles show a strange behaviour. After falling down the height of the bulk isn't correct and afterwards the particles are spreading explosively. The alphaPacked parameter is set to the same value both in explicitCoeffs and relaxationCoeffs (as it should be).

After I have slightly increased the alphaPacked parameter in the relaxationCoeffs to 0.67 the result was suddenly acceptable. I tried the same with the case MPPICFoam/Goldschmidt. Again, the result was logical and seemed right. In further examples I could see that the calculations with the explicit and relaxations models work very well, when alphaPacked parameter in relaxationCoeffs is little higher than in explicitCoeffs (which should not be).
Steps To Reproducetutorials/lagrangian/MPPICFoam/column/constant/kinematicCloudProperties
tutorials/lagrangian/MPPICFoam/Goldschmidt/kinematicCloudProperties

    particleForces
    {
        ErgunWenYuDrag
        {
            alphac alpha.air;
        }
        gravity;
    }

    packingModel explicit;

    dampingModel relaxation;
    relaxationCoeffs
    {
        timeScaleModel
        {
            type nonEquilibrium;
            alphaPacked 0.67; // should be a little higher than in explicitCoeffs
            e 0.9;
        }
    }
TagsNo tags attached.

Activities

will

2019-02-12 14:37

manager   ~0010286

You have not described a bug. MPPIC modelling has its limitations, and if your simulation is failing because of them then your usage is in error. See https://bugs.openfoam.org/rules.php.

Issue History

Date Modified Username Field Change
2019-02-12 12:58 HTauber New Issue
2019-02-12 14:37 will Assigned To => will
2019-02-12 14:37 will Status new => closed
2019-02-12 14:37 will Resolution open => no change required
2019-02-12 14:37 will Note Added: 0010286