View Issue Details

IDProjectCategoryView StatusLast Update
0003162OpenFOAMBugpublic2019-02-08 18:09
ReporterdvillafrAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Version5.0 
Fixed in Version 
Summary0003162: Max and Min Functions not working in Cavitation Models for interPhaseChangeFoam
DescriptionIn the Schnerr-Sauer cavitation model, the variable mDotAlphal term as defined in SchnerrSauer.C has max and min functions which don't seem to work properly...
Cc*limintedAlpha1*pCoeff*max(p-pSat(),p0_),
Cv*(1+alphaNuc()-limitedAlpha1)*pCoeff*min(p-pSat(), p0_)

I have modified the solver so that it writes out the values for mDotAlphal shown above and the results are not consistent with what is coded. If p - pSat > 0 then mDotAlphal[0] should be non-zero and mDotalphal[1] should be zero. If p - pSat < 0 then mDotAlphal[0] should be zero and mDotAlphal[1] should be non-zero. I have seen cells where both mDotAlphal[1] and mDotAlphal[0] become non-zero. This is not consistent with the way the code is written.
TagsNo tags attached.

Activities

henry

2019-02-08 18:09

manager   ~0010284

Not enough information provided to reproduce the problem.

See https://bugs.openfoam.org/rules.php for details of how to report bugs in a useful way.

Issue History

Date Modified Username Field Change
2019-02-08 17:58 dvillafr New Issue
2019-02-08 18:09 henry Assigned To => henry
2019-02-08 18:09 henry Status new => closed
2019-02-08 18:09 henry Resolution open => unable to reproduce
2019-02-08 18:09 henry Note Added: 0010284