View Issue Details

IDProjectCategoryView StatusLast Update
0003087OpenFOAMFeaturepublic2018-10-15 09:07
ReporterPedramAssigned Towill 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version1604
Product Version6 
Fixed in Version 
Summary0003087: wave simulation crash if inlet speed is lower than wave velocity!
DescriptionIn the cases that wave speed defined at inlet is lower than calculated water particle velocity (calculated from wave parameters) solver will crash after some iterations. For example a case setup as bellow where wave speed defined to be zero and water particle velocity at surface can be calculated (analytically) as 0.7 m/s:
inlet
    {
        type waveVelocity;
        origin (0 20 0);
        direction (1 0 0);
        speed 0.0;
        waves
        (
            Airy
            {
                length 17;
                amplitude 0.4;
                phase 0;
                angle 0;
            }
        );
      
    }
Steps To ReproduceI have checked this problem under different scenarios (for 2D and 3D) and always got the same results. It seems other engineers are experiencing the same problem as well.
Problem occurs both for OF 5 and 6. I have attached a sample case in 2D for your consideration.
TagsNo tags attached.

Activities

Pedram

2018-10-12 23:41

reporter  

sendOut.tar.gz (757,945 bytes)

will

2018-10-15 09:07

manager   ~0010102

Reversed flow is more difficult to get right, but the tutorials/interFoam/laminar/wave case runs to completion with the speed set to zero, so the problem is not fundamental, it is with your case.

See https://bugs.openfoam.org/rules.php. "Reports that indicate a significant possibility of user error will be closed or deleted.".

Issue History

Date Modified Username Field Change
2018-10-12 23:41 Pedram New Issue
2018-10-12 23:41 Pedram File Added: sendOut.tar.gz
2018-10-15 09:07 will Assigned To => will
2018-10-15 09:07 will Status new => closed
2018-10-15 09:07 will Resolution open => no change required
2018-10-15 09:07 will Note Added: 0010102