View Issue Details

IDProjectCategoryView StatusLast Update
0003031OpenFOAM[All Projects] Bugpublic2018-08-23 12:15
ReportergklemencicAssigned Tochris 
PrioritynormalSeverityblockReproducibilityhave not tried
Status closedResolutionno change required 
PlatformPCOSLinuxOS VersionUbuntu 18.04LTS
Product Version6 
Fixed in Version 
Summary0003031: Installation Error of the openfoam6 package on Ubuntu 18.04
DescriptionHi there!

I am trying to install the openfoam6 package on Ubuntu 18.04 (on my Workstation in the Company network) according to your installation guide. It starts to install and after some time i get the error message(s):

Err:1 http://downloads.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 openfoam6 amd64 20180805
  403 Forbidden [IP: 216.105.38.13 80]
Err:2 http://downloads.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 paraviewopenfoam54 amd64 0-2
  403 Forbidden [IP: 216.105.38.13 80]
Err:3 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 libboost1.65-dev amd64 1.65.1+dfsg-0ubuntu5
  Connection failed [IP: 91.189.91.23 80]
Err:4 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 libcgal-dev amd64 4.11-2build1
  Connection failed [IP: 91.189.91.23 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/b/boost1.65.1/libboost1.65-dev_1.65.1+dfsg-0ubuntu5_amd64.deb Connection failed [IP: 91.189.91.23 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/universe/c/cgal/libcgal-dev_4.11-2build1_amd64.deb Connection failed [IP: 91.189.91.23 80]
E: Failed to fetch http://downloads.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/openfoam6_20180805_amd64.deb 403 Forbidden [IP: 216.105.38.13 80]
E: Failed to fetch http://downloads.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/paraviewopenfoam54_0-2_amd64.deb 403 Forbidden [IP: 216.105.38.13 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Is there a way to fix that?

Best regards
TagsError, Installation

Relationships

related to 0002979 resolvedchris Unable to install openfoam 5 from "https://openfoam.org/download/5-0-ubuntu/" installation guide 

Activities

wyldckat

2018-08-07 21:09

updater   ~0009916

Given that it failed to download files from the ubuntu.com server(s), then my guess is that there is some problem with the network connection from your workstation to the Internet.

Try to run again the first 2 apt-get commands given at https://openfoam.org/download/6-ubuntu/ to double-check if the same problem still occurs or not.

If it still has problems, check if you are able to update your Ubuntu installation at all, because the problem may not be related to the installation instructions provided here.

If you cannot use apt-get to perform then updates and installations, check if you are able to download the links given in your description, but directly from your web-browser. Because if you are able to download the Deb files this way, then that likely means that you have a problem with the Proxy server connection used at your office.

gklemencic

2018-08-08 08:20

reporter   ~0009920

Hi!

Thanks for your reply, it really helped me and I finally managed to install the package.

There were 2 different problems:

- the sourceforge links were blocked by a kind of "office website blocker", our admin unblocked it for me

- the ubuntu links didn't work for the ubuntuserver that was active in my installation. After changing the servers 2 times it finally worked...

I hope everything works now, thanks for your support!

Best regards

wyldckat

2018-08-08 22:28

updater   ~0009934

@gklemencic: Many thanks for your feedback and I'm glad you've managed to install everything!


@chris: This report and solution is somewhat similar to report #2979, so I've connected both for future reference.
In the meantime, I don't know if there is much that can be added to the installation instructions for these types of situations, namely when downloads fail either due to the mirror servers being down or due to firewalls/proxies preventing access.

chris

2018-08-23 12:15

manager   ~0009995

I agree. If a company sets up a firewall to prevent installation, then it should not install, so the user goes to IT to get it authorised.

Issue History

Date Modified Username Field Change
2018-08-07 13:09 gklemencic New Issue
2018-08-07 13:09 gklemencic Tag Attached: Installation
2018-08-07 13:09 gklemencic Tag Attached: Error
2018-08-07 21:09 wyldckat Note Added: 0009916
2018-08-08 08:20 gklemencic Note Added: 0009920
2018-08-08 22:24 wyldckat Summary Installation Error => Installation Error of the openfoam6 package on Ubuntu 18.04
2018-08-08 22:26 wyldckat Relationship added related to 0002979
2018-08-08 22:26 wyldckat Assigned To => chris
2018-08-08 22:26 wyldckat Status new => assigned
2018-08-08 22:28 wyldckat Note Added: 0009934
2018-08-08 22:52 henry Status assigned => closed
2018-08-08 22:52 henry Resolution open => no change required
2018-08-23 12:15 chris Note Added: 0009995