2018-06-23 13:03 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002979OpenFOAM[All Projects] Bugpublic2018-06-16 12:05
Reporterjulien 
Assigned Tochris 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
PlatformWSL Ubuntu 18.04OSWindows 64 bitsOS Version(please specify)
Product Version5.0 
Target VersionFixed in Version 
Summary0002979: Unable to install openfoam 5 from "https://openfoam.org/download/5-0-ubuntu/" installation guide
Descriptionfollowing the instructions give this error :


Get:26 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libopenmpi-dev amd64 2.1.1-8 [925 kB]
Err:3 https://netix.dl.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 paraviewopenfoam54 amd64 0-2
  Undetermined Error [IP: 87.121.121.2 443]
Fetched 11.6 MB in 2min 4s (93.0 kB/s)
E: Failed to fetch https://netix.dl.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/openfoam5_20180529_amd64.deb Undetermined Error [IP: 87.121.121.2 443]
E: Failed to fetch https://netix.dl.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/paraviewopenfoam54_0-2_amd64.deb Undetermined Error [IP: 87.121.121.2 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Steps To ReproduceFollow the instructions on "https://openfoam.org/download/5-0-ubuntu/"
Additional InformationLooking directly for
 "https://netix.dl.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/paraviewopenfoam54_0-2_amd64.deb"
on the net, I was unable to find the files.
Seems that the right adress is
"https://sourceforge.net/projects/foam/files/foam/ubuntu/dists/..."
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0009746

wyldckat (updater)

The "netix" server is automatically provided by Sourceforge.net as one of several mirrors. It probably wasn't up-to-date or was down.

If you run "sudo apt update" and try to install again, hopefully it will trigger SF.net to switch to another mirror server.

~0009747

julien (reporter)

After the update, the server "excellmedia" seems to be used, but the problem remain :

julien@DESKTOP-S1HKUNR:~$ sudo apt-get -y install openfoam5
...
0 upgraded, 26 newly installed, 0 to remove and 1 not upgraded.
Need to get 130 MB/142 MB of archives.
After this operation, 904 MB of additional disk space will be used.
Err:1 https://excellmedia.dl.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 openfoam5 amd64 20180529
  Could not connect to excellmedia.dl.sourceforge.net:443 (202.153.32.19). - connect (111: Connection refused)
Err:2 https://excellmedia.dl.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 paraviewopenfoam54 amd64 0-2
  Unable to connect to excellmedia.dl.sourceforge.net:https:
E: Failed to fetch https://excellmedia.dl.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/openfoam5_20180529_amd64.deb Could not connect to excellmedia.dl.sourceforge.net:443 (202.153.32.19). - connect (111: Connection refused)
E: Failed to fetch https://excellmedia.dl.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/paraviewopenfoam54_0-2_amd64.deb Unable to connect to excellmedia.dl.sourceforge.net:https:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

~0009748

wyldckat (updater)

I've tested this on my Windows 10 machine at work and installed Ubuntu 18.04 from MS Store and had no problems with the download and installation.

It seems that is some weird network access issue in your machine, either due to a security measure or software. You can try to run:

    wget https://excellmedia.dl.sourceforge.net/project/foam/foam/ubuntu/dists/bionic/main/binary-amd64/openfoam5_20180529_amd64.deb

from within the Ubuntu command line, just to confirm if the same error occurs or not.

If it does give the same error, then:

1- Download this and the other file on your Windows machine with your Internet browser.

2- Then you can copy/move the two files in the Ubuntu command line... the path to the Windows "C:" drive is at "/mnt/c".

3- Then run the following commands for installing:

   sudo dpkg -i openfoam5_20180529_amd64.deb
   sudo dpkg -i paraviewopenfoam54_0-2_amd64.deb
   sudo apt-get install -f
   sudo dpkg-reconfigure openfoam5
   sudo dpkg-reconfigure paraviewopenfoam54

4. Follow the instructions from section "User Configuration" at https://openfoam.org/download/5-0-ubuntu/


Please let us know if any of this worked for you.

~0009749

julien (reporter)

Ok, I tried the command line you proposed "wget..." and it worked!
I have now a package in my home/user file which I don't know how to install...
Can you help me with that?

What conclusions do you draw from that? Do you have any advices to try fixing the problem with my computer?

~0009750

julien (reporter)

Sorry, I suppose I have to follow the points 3 and 4 to install.

~0009751

julien (reporter)

Any way, the installation seems to work fine since it display the help manager.
Thank you for this rapid help!
How can I change the status of the thread?

~0009752

wyldckat (updater)

I'm glad that the manual installation method worked!

It seems like the problem you've gotten can occur sometimes, either due a 3rd party anti-virus or 3rd party firewall software or due to some weird IPv6 issues, from what I can see on the issues on WSL: https://github.com/Microsoft/WSL/issues?utf8=%E2%9C%93&q=is%3Aissue+apt-get+permission+denied - but it's not clear on what happened in your situation.


As for the status of this thread/report - @Chris: I don't know if you want to add this workaround to the page https://openfoam.org/download/windows-10/ - see comment ~0009748 above, or if we'll wait for a couple more similar occurrences to be reported here?

~0009753

chris (manager)

I tried it myself from an Ubuntu 18.04 instance with "apt-get -y install openfoam5". Initially I got:

Err:2 https://vorboss.dl.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 openfoam5 amd64 20180529
  Could not wait for server fd - select (11: Resource temporarily unavailable) [IP: 5.10.152.194 443]
Get:3 https://vorboss.dl.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 paraviewopenfoam54 amd64 0-2 [48.8 MB]
Fetched 268 MB in 3min 2s (1474 kB/s)

In other words, from the same server one pack downloaded and one failed.

When I tried again, I got:

Get:1 https://netcologne.dl.sourceforge.net/project/foam/foam/ubuntu bionic/main amd64 openfoam5 amd64 20180529 [81.3 MB]
Fetched 81.3 MB in 2s (35.2 MB/s)

Admittedly the first one was not "Connection: refused", unlike the report.

Lets wait on this. Documentation must be simple to be accessible to the widest audience, and adding information that is rarely needed makes it complex.

~0009778

chris (manager)

Let's close. If the problem recurs then we can look at this again.
+Notes

-Issue History
Date Modified Username Field Change
2018-06-13 08:47 julien New Issue
2018-06-13 11:10 wyldckat Note Added: 0009746
2018-06-13 11:35 julien Note Added: 0009747
2018-06-13 12:08 wyldckat Note Added: 0009748
2018-06-13 13:00 julien Note Added: 0009749
2018-06-13 13:05 julien Note Added: 0009750
2018-06-13 13:36 julien Note Added: 0009751
2018-06-13 13:48 wyldckat Note Added: 0009752
2018-06-13 15:34 chris Note Added: 0009753
2018-06-16 12:05 chris Assigned To => chris
2018-06-16 12:05 chris Status new => resolved
2018-06-16 12:05 chris Resolution open => fixed
2018-06-16 12:05 chris Note Added: 0009778
+Issue History