View Issue Details

IDProjectCategoryView StatusLast Update
0002788OpenFOAM[All Projects] Bugpublic2018-07-10 11:24
ReporterPfiffikusAssigned Tochris 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformUnixOSOtherOS Version(please specify)
Product Version5.0 
Fixed in Version 
Summary0002788: Docker instance hangs!?
DescriptionThe final
openfoam5-linux -d /root/OpenFOAM/root-5.0 -x localMachineID
does NOT respond ...
Steps To ReproduceFollowing https://openfoam.org/download/5-0-linux/ I ended up with a modified command as step 5 due to the fact that I was logged in to a remote machine from a VWware Linux. Whereas a xterm opens smoothly I get no command prompt after execution of aforementioned command :(
Additional InformationThe remote machine with Docker installed is an debian 8.6
with 3.16.0-4-amd64 kernel.
Tagsdocker, linux, remote login

Relationships

related to 0002799 closedchris Stuck at installation after downloading 

Activities

wyldckat

2017-12-12 20:46

updater   ~0009149

The first detail I want to point out is that running 'openfoam5-linux' from the 'root' account is - for the lack of a better term - really dangerous. At the very least, dangerous if this is done regularly with any docker container.
Therefore, I strongly urge you to run the script 'openfoam5-linux' as a normal user.

The second detail is that the argument 'localMachineID' after '-x' is not used.


Now, regarding the description you gave in the "Steps to Reproduce" section, I'm confused by your description.... If I understood you correctly:

 1. You have a remote machine that is running Debian and has Docker installed inside it. It is in this machine that you ran the script 'openfoam5-linux'.

 2. You accessed the remote machine from another machine, namely a virtual machine that is running some Linux distribution.

 3. You ran the 'xterm' command, which worked just fine...

 4. ... But here is where you lost me.


What exactly did you mean by "I get no command prompt after execution of aforementioned command"?
Do you mean that:

 1. While 'xterm' is running, you have no control over the terminal where you ran the script 'openfoam5-linux'?

 2. Or that inside the 'xterm' window, there is no command line?

Pfiffikus

2017-12-13 14:24

reporter   ~0009157

> At the very least, dangerous if this is done regularly with any docker container.
okay, but root should be allowed/able to check its installation for correctness!?

> ... argument 'localMachineID' after '-x' is not used.
just the argument!? Fine, it simplifies the usage :)

> I get no command prompt after execution of aforementioned command
describes my expectation: Runs the script in background during any additional command, i.e. step 6, instead offering a command prompt?
What's the result/respond of executing step 5? Currently I could not continue after the execution, because no commands are accepted after returning
Launching /usr/bin/openfoam5-linux
User: "root" (ID 0, group ID 0)

The xterm just confirms the correct setting of DISPLAY in the shell I use for step 5 afterwards ... :)

wyldckat

2017-12-14 15:40

updater   ~0009160

> > At the very least, dangerous if this is done regularly with any docker container.

> okay, but root should be allowed/able to check its installation for correctness!?

If you do that, it's at your own risk. Containers are always a risk of having an unexpected bug that could lead to damaging the host system, if root access is given to it. Even though Docker should not allow for this to happen... in the past there were bugs that gave this risk.


> The xterm just confirms the correct setting of DISPLAY in the shell I use for step 5 afterwards ... :)

From your description, it seems that you ran 'xterm' after
'openfoam5-linux' stopped working.

I don't have a machine handy right now that has the Docker installation with openfoam5-linux, in order to show an image on what to expect.


@Chris: Any chance you can add a picture or youtube video in step #5 at https://openfoam.org/download/5-0-linux/ - that shows what to expect from the command line?

chris

2017-12-18 20:58

manager   ~0009165

@Pfiffikus @wyldckat

I was able to reproduce this problem on Debian Jessie.

It is caused by a recent bug in docker version 17.11.0, see this thread:
https://github.com/moby/moby/issues/35587

Downgrading to v 17.10.0 resolves the issue. You can downgrade with the following command:
sudo apt-get install docker-ce=17.10.0~ce-0~debian

==================================================

While checking this I tested Ubuntu, CentOS, Fedora and SLES - all fine.

But it does not run from instructions on RHEL v7: when I tried to install, it states RHEL now only supports the Enterprise Edition, see https://docs.docker.com/engine/installation/

Issue History

Date Modified Username Field Change
2017-12-12 17:09 Pfiffikus New Issue
2017-12-12 17:09 Pfiffikus Tag Attached: docker linux remote login
2017-12-12 20:46 wyldckat Note Added: 0009149
2017-12-13 14:24 Pfiffikus Note Added: 0009157
2017-12-13 16:30 Pfiffikus Tag Detached: docker linux remote login
2017-12-13 16:30 Pfiffikus Tag Attached: OpenFoam 5.x
2017-12-13 16:30 Pfiffikus Tag Attached: docker
2017-12-13 16:30 Pfiffikus Tag Attached: linux
2017-12-13 16:30 Pfiffikus Tag Attached: remote login
2017-12-14 15:40 wyldckat Note Added: 0009160
2017-12-18 20:58 chris Note Added: 0009165
2017-12-18 20:59 chris Assigned To => chris
2017-12-18 20:59 chris Status new => closed
2017-12-18 20:59 chris Resolution open => fixed
2017-12-23 22:13 wyldckat Relationship added related to 0002799
2018-07-10 11:24 administrator Tag Detached: OpenFoam 5.x