View Issue Details

IDProjectCategoryView StatusLast Update
0002755ThirdParty[All Projects] Bugpublic2018-07-10 11:24
ReporterSadeghEbadiAssigned Tochris 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Product Version5.x 
Fixed in Version5.x 
Summary0002755: Problem while compiling Paraview 5.4.0 through installing OF 5.x using source code
DescriptionWhen I try to compile Paraview 5.4.0, after that praview had been downloaded it gives this error:
CMake Error at VTK/GUISupport/Qt/CMakeLists.txt:69 (find_package):
  By not providing "FindQt5.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5" with any of
  the following names:


  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files. If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.

-- Configuring incomplete, errors occurred!
See also "/opt/ThirdParty-5.0/build/linux64Gcc/ParaView-5.4.0/CMakeFiles/CMakeOutput.log".
See also "/opt/ThirdParty-5.0/build/linux64Gcc/ParaView-5.4.0/CMakeFiles/CMakeError.log".

What is the soulution?
TagsParaview 5.4.0, wmake


related to 0002640 resolvedhenry Stop at the build of paraview (5.4.0) 



2017-11-12 19:52


1.png (80,684 bytes)
1.png (80,684 bytes)


2017-11-12 20:17

updater   ~0009020

If you want to build OpenFOAM 5.x, you should follow the instructions given here: - which means that you should also use the source code repository for ThirdParty-5.x, not the 5.0 folder.
This is because this specific bug you have tripped on was fixed on ThirdParty-5.x:

I'll close and mark this as already solved.


2017-11-13 11:11

reporter   ~0009024

I'm sorry for reopening this. But on the bug you had issued I couldn't found the solution!
Can you tell me clearly, what should I do in order to solve this?


2017-11-13 11:15

reporter   ~0009025

I had run export QT_SELECT=qt4 in this path: /opt/ThirdParty-5.0-----> But after running ./makeParaView I got the same error!


2017-11-13 11:19

updater   ~0009026

In the instructions provided here:
... more specifically here:

... it's indicated that you should download the respective "ThirdParty-*" version package.

Therefore, since you are using OpenFOAM 5.x, you should download the respective package from here:
For example, you can do that by running:

   git clone

That is why I referred you to the other 2 links on my previous comment.


2017-11-13 12:46

reporter   ~0009027

Thanks dear Bruno,
I have followed the provided instructions but again after running ./makeParaView command I get the following message! What should I do now?

linux7@linux7-All-Series:/opt/ThirdParty-5.x$ ./makeParaView
Downloading ParaView-5.4.0
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 41.7M 100 41.7M 0 0 62969 0 0:11:34 0:11:34 --:--:-- 378k
*** Error: Qt 5 version provided < 5.6
*** Please use the -qmake option to specify the location of a version of Qt >= 5.6
*** e.g.
*** -qmake /usr/local/qt-5.6.0/bin/qmake
*** -qmake /opt/ThirdParty-5.x/platforms/linux64Gcc/qt-5.6.0/bin/qmake


2017-11-13 13:41

updater   ~0009028


  * Install packages for ParaView

       sudo apt-get install qt4-dev-tools libqt4-dev libqt4-opengl-dev freeglut3-dev libqtwebkit-dev

From - run the following before "makeParaView":

  export QT_SELECT=qt4

Afterwards it should work as intended, because this is how Qt 4 is selected on Ubuntu.


2017-11-13 19:38

reporter   ~0009029

Thanks dear Bruno after all I could install it.


2017-11-13 19:46

updater   ~0009030

@Chris: In page - section "Installing dependent packages on Ubuntu (versions 14.04 or above)" - please add the following information for building ParaView:

  * Note: If Qt 5 is also installed in Ubuntu, the following should be executed before running makeParaView:

        export QT_SELECT=qt4


2017-11-13 20:04

manager   ~0009031

I have done what you suggested, but if using Ubuntu 16.04 why not just install the 5.x pack?:

Issue History

Date Modified Username Field Change
2017-11-12 19:52 SadeghEbadi New Issue
2017-11-12 19:52 SadeghEbadi File Added: 1.png
2017-11-12 19:52 SadeghEbadi Tag Attached: wmake
2017-11-12 19:52 SadeghEbadi Tag Attached: OpenFoam 5.x
2017-11-12 19:52 SadeghEbadi Tag Attached: Paraview 5.4.0
2017-11-12 20:17 wyldckat Note Added: 0009020
2017-11-12 20:17 wyldckat Priority high => normal
2017-11-12 20:17 wyldckat Category Contribution => Bug
2017-11-12 20:17 wyldckat Relationship added related to 0002640
2017-11-12 20:17 wyldckat Assigned To => wyldckat
2017-11-12 20:17 wyldckat Status new => closed
2017-11-12 20:17 wyldckat Resolution open => fixed
2017-11-12 20:17 wyldckat Fixed in Version => 5.x
2017-11-13 11:11 SadeghEbadi Status closed => feedback
2017-11-13 11:11 SadeghEbadi Resolution fixed => reopened
2017-11-13 11:11 SadeghEbadi Note Added: 0009024
2017-11-13 11:15 SadeghEbadi Note Added: 0009025
2017-11-13 11:15 SadeghEbadi Status feedback => assigned
2017-11-13 11:19 wyldckat Note Added: 0009026
2017-11-13 12:46 SadeghEbadi Note Added: 0009027
2017-11-13 13:41 wyldckat Note Added: 0009028
2017-11-13 19:38 SadeghEbadi Note Added: 0009029
2017-11-13 19:46 wyldckat Note Added: 0009030
2017-11-13 19:46 wyldckat Assigned To wyldckat =>
2017-11-13 19:46 wyldckat Assigned To => chris
2017-11-13 20:04 chris Note Added: 0009031
2017-11-13 20:04 chris Status assigned => closed
2017-11-13 20:04 chris Resolution reopened => fixed
2018-07-10 11:24 administrator Tag Detached: OpenFoam 5.x