2017-11-24 09:10 GMT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002755ThirdParty[All Projects] Bugpublic2017-11-13 20:04
ReporterSadeghEbadi 
Assigned Tochris 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Product Version5.x 
Target VersionFixed in Version5.x 
Summary0002755: Problem while compiling Paraview 5.4.0 through installing OF 5.x using source code
DescriptionWhen I try to compile Paraview 5.4.0, after that praview had been downloaded it gives this error:
CMake Error at VTK/GUISupport/Qt/CMakeLists.txt:69 (find_package):
  By not providing "FindQt5.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5" with any of
  the following names:

    Qt5Config.cmake
    qt5-config.cmake

  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files. If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/opt/ThirdParty-5.0/build/linux64Gcc/ParaView-5.4.0/CMakeFiles/CMakeOutput.log".
See also "/opt/ThirdParty-5.0/build/linux64Gcc/ParaView-5.4.0/CMakeFiles/CMakeError.log".

What is the soulution?
Thanks
Sadegh
TagsOpenFoam 5.x, Paraview 5.4.0, wmake
Attached Files
  • png file icon 1.png (80,684 bytes) 2017-11-12 19:52 -
    png file icon 1.png (80,684 bytes) 2017-11-12 19:52 +

-Relationships
related to 0002640resolvedhenry Stop at the build of paraview (5.4.0) 
+Relationships

-Notes

~0009020

wyldckat (updater)

If you want to build OpenFOAM 5.x, you should follow the instructions given here: https://openfoam.org/download/source/ - which means that you should also use the source code repository for ThirdParty-5.x, not the 5.0 folder.
This is because this specific bug you have tripped on was fixed on ThirdParty-5.x: https://bugs.openfoam.org/view.php?id=2640

I'll close and mark this as already solved.

~0009024

SadeghEbadi (reporter)

I'm sorry for reopening this. But on the bug you had issued I couldn't found the solution!
Can you tell me clearly, what should I do in order to solve this?

~0009025

SadeghEbadi (reporter)

I had run export QT_SELECT=qt4 in this path: /opt/ThirdParty-5.0-----> But after running ./makeParaView I got the same error!

~0009026

wyldckat (updater)

In the instructions provided here: https://openfoam.org/download/source/
... more specifically here: https://openfoam.org/download/source/downloading-source-code/

... it's indicated that you should download the respective "ThirdParty-*" version package.

Therefore, since you are using OpenFOAM 5.x, you should download the respective package from here: https://github.com/OpenFOAM/ThirdParty-5.x
For example, you can do that by running:

   git clone https://github.com/OpenFOAM/ThirdParty-5.x.git

That is why I referred you to the other 2 links on my previous comment.

~0009027

SadeghEbadi (reporter)

Thanks dear Bruno,
I have followed the provided instructions but again after running ./makeParaView command I get the following message! What should I do now?

linux7@linux7-All-Series:/opt/ThirdParty-5.x$ ./makeParaView
Downloading ParaView-5.4.0
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 41.7M 100 41.7M 0 0 62969 0 0:11:34 0:11:34 --:--:-- 378k
*** Error: Qt 5 version provided < 5.6
*** Please use the -qmake option to specify the location of a version of Qt >= 5.6
*** e.g.
*** -qmake /usr/local/qt-5.6.0/bin/qmake
*** -qmake /opt/ThirdParty-5.x/platforms/linux64Gcc/qt-5.6.0/bin/qmake

~0009028

wyldckat (updater)

From https://openfoam.org/download/source/software-for-compilation/

  * Install packages for ParaView

       sudo apt-get install qt4-dev-tools libqt4-dev libqt4-opengl-dev freeglut3-dev libqtwebkit-dev


From https://bugs.openfoam.org/view.php?id=2640 - run the following before "makeParaView":

  export QT_SELECT=qt4


Afterwards it should work as intended, because this is how Qt 4 is selected on Ubuntu.

~0009029

SadeghEbadi (reporter)

Thanks dear Bruno after all I could install it.

~0009030

wyldckat (updater)

@Chris: In page https://openfoam.org/download/source/software-for-compilation/ - section "Installing dependent packages on Ubuntu (versions 14.04 or above)" - please add the following information for building ParaView:

  * Note: If Qt 5 is also installed in Ubuntu, the following should be executed before running makeParaView:

        export QT_SELECT=qt4

~0009031

chris (manager)

I have done what you suggested, but if using Ubuntu 16.04 why not just install the 5.x pack?:
https://openfoam.org/news/v5-0-patch/
+Notes

-Issue History
Date Modified Username Field Change
2017-11-12 19:52 SadeghEbadi New Issue
2017-11-12 19:52 SadeghEbadi File Added: 1.png
2017-11-12 19:52 SadeghEbadi Tag Attached: wmake
2017-11-12 19:52 SadeghEbadi Tag Attached: OpenFoam 5.x
2017-11-12 19:52 SadeghEbadi Tag Attached: Paraview 5.4.0
2017-11-12 20:17 wyldckat Note Added: 0009020
2017-11-12 20:17 wyldckat Priority high => normal
2017-11-12 20:17 wyldckat Category Contribution => Bug
2017-11-12 20:17 wyldckat Relationship added related to 0002640
2017-11-12 20:17 wyldckat Assigned To => wyldckat
2017-11-12 20:17 wyldckat Status new => closed
2017-11-12 20:17 wyldckat Resolution open => fixed
2017-11-12 20:17 wyldckat Fixed in Version => 5.x
2017-11-13 11:11 SadeghEbadi Status closed => feedback
2017-11-13 11:11 SadeghEbadi Resolution fixed => reopened
2017-11-13 11:11 SadeghEbadi Note Added: 0009024
2017-11-13 11:15 SadeghEbadi Note Added: 0009025
2017-11-13 11:15 SadeghEbadi Status feedback => assigned
2017-11-13 11:19 wyldckat Note Added: 0009026
2017-11-13 12:46 SadeghEbadi Note Added: 0009027
2017-11-13 13:41 wyldckat Note Added: 0009028
2017-11-13 19:38 SadeghEbadi Note Added: 0009029
2017-11-13 19:46 wyldckat Note Added: 0009030
2017-11-13 19:46 wyldckat Assigned To wyldckat =>
2017-11-13 19:46 wyldckat Assigned To => chris
2017-11-13 20:04 chris Note Added: 0009031
2017-11-13 20:04 chris Status assigned => closed
2017-11-13 20:04 chris Resolution reopened => fixed
+Issue History