View Issue Details

IDProjectCategoryView StatusLast Update
0002640ThirdPartyBugpublic2017-11-12 20:17
Reportersariew Assigned Tohenry  
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSLinux MintOS Version17.1
Summary0002640: Stop at the build of paraview (5.4.0)
Descriptionin $WM_THIRD_PARTY_DIR

0 ./Allwmake
1 ./makeCmake (cmake-3.5.1, because it is necessary for PV5.4.0)
2 ./makeParaView

but CMake Error at VTK/GUISupport/Qt/CMakeLists.txt:69 (find_package): ...
What shuld I do?
TagsNo tags attached.


related to 0002661 closedwyldckat OpenFOAM Installing parafoam stall due to lack of qt5 packages 
related to 0002673 closedwyldckat OpenFOAM paraFoam libprotobuf FATAL 
related to 0002755 closedchris ThirdParty Problem while compiling Paraview 5.4.0 through installing OF 5.x using source code 



2017-07-28 10:27


errorLogs.tar.gz (18,167 bytes)


2017-07-30 21:04

updater   ~0008476

Run the following command before running makeParaView:

  export QT_SELECT=qt4

And please let us know if it solves the issue for you.

For future reference, Linux Mint 17.1 is based on Ubuntu 14.04.


2017-07-31 02:00


myPrnt.env.tar.gz (2,273 bytes)


2017-07-31 02:00

reporter   ~0008477

Thanks for your advice but did not work.

What should i do next?


2017-07-31 09:42

updater   ~0008478

You can try to install Qt5 and use that version instead.

Installing (haven't tested this myself):

  sudo apt-get install qt5-dev-tools libqt5-dev

Then before running makeParaView:

  export QT_SELECT=qt5


2017-07-31 10:50

reporter   ~0008479

I'm sorry but I will not try the above solution.
Because i was able to successfully install COM version (v1706)
on same environment, and it works fine!.

I don't know the reason at all, but I'm afraid that there
is a radical error in this release.


2017-07-31 11:33

manager   ~0008480

@wyldckat We've been running the following to build paraview on old ubuntus:

    ./makeParaView PARAVIEW_QT_VERSION=4

This variable gets passed to cmake and affects the build that way.

I haven't come across the QT_SELECT variable, and I can't find any reference to it in the paraview sources, so I assume it interacts with Qt directly in a non-paraview specific way. You know more about building on funny platforms than I do; is the QT_SELECT method preferred?


2017-07-31 11:44

updater   ~0008481

@will 'QT_SELECT' is something that Ubuntu uses, possibly inherited from Debian, for selecting between Qt versions that are installed on the system. If I remember correctly, there is a 'qmake' script in the '/etc/alternatives' that does the selection of the version in accordance with this environment variable.

'PARAVIEW_QT_VERSION' is the first time I see the need to use this... it should have been detected automatically by either CMake or makeParaView :(

However, I haven't managed to look better into the 5.3.0 and 5.4.0 releases of ParaView (FYI 5.4.1 is currently in RC2). The changes they've done to the internal CMake scripts in ParaView for Qt detection seems to have some issues, as I mentioned in another report.


2017-07-31 11:47

updater   ~0008482

@sariew Many thanks for the feedback and my apologies for not given you a better solution any faster. I haven't had the time to test this myself, so I had to go with the solutions I was already aware of.

Also please keep in mind that starting with ParaView 5.5, Qt5 is the only major version of Qt supported by Kitware. This was what I had in the back of my mind when I gave the solution to use Qt5 instead.


2017-07-31 12:35

manager   ~0008483

All the builds of ParaView 5.4.0 for the packaged versions of OpenFOAM for Ubuntu 14.04, 16.04 and 17.04 are using QT 4. We support Ubuntu - meaning we compile and test on it. We don't support Mint.


2017-08-02 03:05

reporter   ~0008492

I had this issue and it seems to be related to cmake version which should be 3.8+. I updated my cmake and problem was resolved. I used Qt5 and cmake 3.9 for building Paraview 5.4.


2017-08-02 04:04

reporter   ~0008493

Thanks to the advice here.
I was able to successfully install it but ParaView doesn't start this time.
So, I installed it on lubuntu (14.04.5) in the virtual environment, but there was no problem....


2017-08-13 16:22



2017-08-13 16:23


proposition_2640_v1.patch (1,998 bytes)   
diff --git a/etc/tools/ParaViewFunctions b/etc/tools/ParaViewFunctions
index 21fe264..9c23034 100644
--- a/etc/tools/ParaViewFunctions
+++ b/etc/tools/ParaViewFunctions
@@ -174,7 +174,7 @@ addCMakeVariable()
     for var in $*
@@ -374,14 +374,26 @@ addQtSupport()
-        if [ $QtMajor -lt 4 -o $QtMajor -eq 4 -a $QtMinor -lt 5 ]
+        if [ $QtMajor -lt 4 -o $QtMajor -eq 4 -a $QtMinor -lt 7 ]
-            echo "*** Error: Qt version provided < 4.5"
-            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.5"
+            echo "*** Error: Qt 4 version provided < 4.7"
+            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.7"
             echo "***     e.g."
-            echo "***         -qmake /usr/local/qt-4.6.2/bin/qmake"
-            echo "***         -qmake $installBASE/qt-4.6.2/bin/qmake"
+            echo "***         -qmake /usr/local/qt-4.7.2/bin/qmake"
+            echo "***         -qmake $installBASE/qt-4.7.2/bin/qmake"
             exit 1
+        elif [ $QtMajor -eq 5 -a $QtMinor -lt 6 ]
+        then
+            echo "*** Error: Qt 5 version provided < 5.6"
+            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 5.6"
+            echo "***     e.g."
+            echo "***         -qmake /usr/local/qt-5.6.0/bin/qmake"
+            echo "***         -qmake $installBASE/qt-5.6.0/bin/qmake"
+            exit 1
+        else
+            # Enforce the Qt version to be used, so that users don't have to
+            # guess how to tell ParaView to use the desired Qt version
+            addCMakeVariable "PARAVIEW_QT_VERSION=$QtMajor"
         echo "*** Error: cannot find qmake either at \$QMAKE_PATH or in current \$PATH"
proposition_2640_v1.patch (1,998 bytes)   


2017-08-13 16:39

updater   ~0008565

@Henry: I've attached the following files:

  - "proposition_2640_v1.patch" - for easily seeing the changes being proposed with this comment.

  - "ParaViewFunctions.proposition_2640_v1" - for updating the file "etc/tools/ParaViewFunctions", which was tested with OpenFOAM-dev, but should also work with OpenFOAM 5.*

So the proposed changes are as follows:

 1. Also have a Qt version check for the valid Qt 5 series, since ParaView 5.4.0 requires at least Qt 5.6.

 2. Automatically add the "PARAVIEW_QT_VERSION" variable to the CMake variable stack, based on the current Qt version that qmake states that it's using.

I've tested this on Ubuntu 14.04 and 16.04, both x86_64.

@Chris and @Will: This proposition will solve the problem that most people have been having lately when simply running 'makeParaView'.

But if users have installed Qt 5 and Qt 4 in their Ubuntu systems, then 'qmake' will use Qt 5 by default. The way used in Ubuntu and Debian for changing between the two Qt versions is to define the environment variable "QT_SELECT" with the desired version. Therefore, the installation instructions at could indicate that on Ubuntu that the following is used before running 'makeParaView':

  export QT_SELECT=qt4

But then again, once ParaView 5.5 or 6.0 is released, this won't be much of a problem any more...

For completion sake, a few more important for potential future issues:

 1. Ubuntu 16.04 provides Qt 5.5.1, which is not supported with ParaView 5.4.0. This means that future ParaView 5.5/6.0 builds will be a pain to support in Ubuntu 16.04 and older, possibly requiring the use of a Ubuntu backports repository.

 2. I had tried to install Qt 5 on my Ubuntu 16.04 and the following command installed the packages that were needed:

      sudo apt-get install qt5-default libqt5x11extras5-dev

    However, since Qt 5.5.1 doesn't work with ParaView 5.4.0, I had to remove them and had to use the following command:

      sudo apt-get remove --purge qt5-default libqt5x11extras5-dev qtbase5-dev-tools libqt5opengl5-dev qt5-default libqt5concurrent5 qt5-qmake qtbase5-dev


2017-08-14 10:40

manager   ~0008571

Thanks Bruno, I have pushed your fix to OpenFOAM-dev and OpenFOAM-5.x for testing and will leave this report open for a short while during this period.

Issue History

Date Modified Username Field Change
2017-07-28 10:27 sariew New Issue
2017-07-28 10:27 sariew File Added: errorLogs.tar.gz
2017-07-30 21:04 wyldckat Note Added: 0008476
2017-07-31 02:00 sariew File Added: myPrnt.env.tar.gz
2017-07-31 02:00 sariew Note Added: 0008477
2017-07-31 09:42 wyldckat Note Added: 0008478
2017-07-31 10:50 sariew Note Added: 0008479
2017-07-31 11:33 will Note Added: 0008480
2017-07-31 11:44 wyldckat Note Added: 0008481
2017-07-31 11:47 wyldckat Note Added: 0008482
2017-07-31 12:35 chris Note Added: 0008483
2017-08-02 03:05 taherc Note Added: 0008492
2017-08-02 04:04 sariew Note Added: 0008493
2017-08-10 13:41 wyldckat Relationship added related to 0002661
2017-08-13 16:22 wyldckat File Added: ParaViewFunctions.proposition_2640_v1
2017-08-13 16:23 wyldckat File Added: proposition_2640_v1.patch
2017-08-13 16:39 wyldckat Note Added: 0008565
2017-08-13 16:39 wyldckat Assigned To => henry
2017-08-13 16:39 wyldckat Status new => assigned
2017-08-14 10:40 henry Note Added: 0008571
2017-08-22 14:58 henry Status assigned => resolved
2017-08-22 14:58 henry Resolution open => fixed
2017-08-23 19:26 wyldckat Relationship added related to 0002673
2017-11-12 20:17 wyldckat Relationship added related to 0002755