View Issue Details

IDProjectCategoryView StatusLast Update
0002733OpenFOAM[All Projects] Bugpublic2017-10-24 14:51
ReporterTomFAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuSEOS VersionLeap 42.3
Product Version5.x 
Fixed in Versiondev 
Summary0002733: When running simpleFoam -postProcess porosity forces are not taken into account
DescriptionFor a particular project the forces on a porous zone may be requested after the run was finished. When running the -postProcess option of simpleFoam, the porosity forces remained 0, while there are nonzero forces reported during the run when it is restarted.
Steps To ReproduceRun the attached modified angledDuctExplicit tutorial case and compare the forces report in log.simpleFoam and log.forces.
Additional InformationProbably the porous zone is not created during the postProcess part, maybe this is intentional?
TagspostProcess porosity

Relationships

related to 0002735 resolvedhenry update error 

Activities

TomF

2017-10-23 14:50

reporter  

angledDuctExplicit.tgz (4,561 bytes)

henry

2017-10-23 22:25

manager   ~0008923

Thanks for the bug report, this is an interesting problem the solution to which may have some problematic side-effects. I have made the necessary change to simpleFoam in OpenFOAM-dev:

commit a096a491fcfd8e2166e3ef0e8aca6c4efd0133da

could you test it and if it proves satisfactory I will make the equivalent change to the other solvers.

taherc

2017-10-24 04:01

reporter   ~0008924

After the commit compilation of porousSimpleFoam fails due to re-declaration of createFvOptions. The line "#include "createFvOptions.H"" should be remove from porousSimpleFoam.C:54.

henry

2017-10-24 08:27

manager   ~0008925

commit d7723455c7030438e602090c350062728039822c

TomF

2017-10-24 08:34

reporter   ~0008926

I can confirm the fix works thank you!

henry

2017-10-24 14:51

manager   ~0008929

Resolved by commit a096a491fcfd8e2166e3ef0e8aca6c4efd0133da

See also commit 73e24df8e0b6b3a30512ca0b88feb8da79e65ea1

Issue History

Date Modified Username Field Change
2017-10-23 14:50 TomF New Issue
2017-10-23 14:50 TomF File Added: angledDuctExplicit.tgz
2017-10-23 14:50 TomF Tag Attached: postProcess porosity
2017-10-23 22:25 henry Note Added: 0008923
2017-10-24 04:01 taherc Note Added: 0008924
2017-10-24 08:27 henry Note Added: 0008925
2017-10-24 08:34 TomF Note Added: 0008926
2017-10-24 11:44 wyldckat Relationship added related to 0002735
2017-10-24 14:51 henry Assigned To => henry
2017-10-24 14:51 henry Status new => resolved
2017-10-24 14:51 henry Resolution open => fixed
2017-10-24 14:51 henry Fixed in Version => dev
2017-10-24 14:51 henry Note Added: 0008929