View Issue Details

IDProjectCategoryView StatusLast Update
0000259OpenFOAM[All Projects] Bugpublic2011-09-12 16:20
Reporteruser233Assigned Touser2 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuseOS Version11.1
Product Version 
Fixed in Version 
Summary0000259: third-party Qt to path
DescriptionThis should really be a note added to a previous report 0000127, which has been closed because it could not be reproduced. I observed the same error as the original poster upon running paraFoam (/opt/paraviewopenfoam381/lib/paraview-3.8/paraview: symbol lookup error: /opt/paraviewopenfoam381/lib/paraview-3.8/libpqWidgets.so: undefined symbol: _ZNK16QAbstractSpinBox16inputMethodQueryEN2Qt16InputMethodQueryE). In my case, the problem was resolved by adding my ThirdParty-2.0.x version of Qt to my paths; e.g.
  setenv QT_DIR $env(WM_THIRD_PARTY_DIR)/platforms/$env(WM_ARCH)$env(WM_COMPILER)/qt-4.7.3
  prepend-path LD_LIBRARY_PATH $env(QT_DIR)/lib
  prepend-path PATH $env(QT_DIR)/bin

Perhaps this could be automatically handled with a config/qt.csh file, or perhaps a note in ThirdParty-2.0.x/rREADME.html would be helpful.
TagsNo tags attached.

Relationships

has duplicate 0000288 resolveduser2 ThirdParty paraFoam/paraview don't start when using locally compiled qt 

Activities

user2

2011-09-12 16:20

  ~0000651

Thanks for your feedback - I've added some notes to the ThirdParty README file under commit:

    64e0ccbeaf631aeb14a12ec06bbca1dd6552a22b

Issue History

Date Modified Username Field Change
2011-07-20 17:25 user233 New Issue
2011-09-12 16:20 user2 Note Added: 0000651
2011-09-12 16:20 user2 Status new => resolved
2011-09-12 16:20 user2 Fixed in Version => 2.0.x
2011-09-12 16:20 user2 Resolution open => fixed
2011-09-12 16:20 user2 Assigned To => user2
2011-09-12 16:25 user2 Relationship added has duplicate 0000288