View Issue Details

IDProjectCategoryView StatusLast Update
0000288ThirdParty[All Projects] Bugpublic2011-09-12 16:35
Reporteruser47Assigned Touser2 
PrioritynormalSeveritytweakReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformLinuxOSScientific Linux 6.1OS Versionx86_64
Product Version 
Fixed in Version 
Summary0000288: paraFoam/paraview don't start when using locally compiled qt
DescriptionThis is an odd "bug" I've encountered on this version of Linux, but not on my debian-based machines, while using the same compilation procedures..

So. I've been compiling the ThirdParty application, with local cmake, qt and paraview, and when starting paraview and/or paraFoam, I get the following error:

/home/ftpronk/OpenFOAM/ThirdParty-2.0.x/platforms/linux64Gcc/paraview-3.10.1/lib/paraview-3.10/paraview: symbol lookup error: /home/ftpronk/OpenFOAM/ThirdParty-2.0.x/platforms/linux64Gcc/paraview-3.10.1/lib/paraview-3.10/libpqComponents.so: undefined symbol: _ZN15QSplitterHandle11resizeEventEP12QResizeEven

I thought it might be an issue due to something not happening correctly during the compiling process due to gcc incompatibilities (that wouldn't be the first time..) so I decided to recompile everything with a local gcc (4.5.1), but in the end got the same error.
Steps To Reproduce- Compile the paraview applications with local gcc (and needed 'dependencies' like gmp, mpc etc.), local cmake, qt4.
- Modify makeParaview script to point to local qmake
- Run paraview.
Additional InformationIn the end, it appeared that the error was due to the local qt libraries no being present in the LD_LIBRARY_PATH.

So doing something like:

LD_LIBRARY_PATH=~/OpenFOAM/ThirdParty-2.0.x/platforms/linux64Gcc/qt-4.7.3/lib:$LD_LIBRARY_PATH

solved the problem.

What is odd, is that on my Debian install, I also compiled paraview with a local qt, and the qt library is not included in LD_LIBRARY_PATH, but I don't get this issue.. The only difference in the compilation process is that I used ./makeParaview -qmake instead of changing the ./makeParaview script.

Kind regards,

Francois.
TagsNo tags attached.

Relationships

duplicate of 0000259 resolveduser2 OpenFOAM third-party Qt to path 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-09-09 10:32 user47 New Issue
2011-09-12 16:25 user2 Relationship added duplicate of 0000259
2011-09-12 16:35 user2 Status new => resolved
2011-09-12 16:35 user2 Fixed in Version => 2.0.x
2011-09-12 16:35 user2 Resolution open => fixed
2011-09-12 16:35 user2 Assigned To => user2