View Issue Details

IDProjectCategoryView StatusLast Update
0001855OpenFOAM[All Projects] Bugpublic2015-10-27 15:34
Reporteruser1210Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status newResolutionreopened 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001855: decomposePar+refinementHistory doesn't work
DescriptionFor any *DyMFoam solver, decomposePar is not working for refinementHistory file, which is stored in polyMesh folder in time folders. This disables the unrefinement process in parallel run.
TagsNo tags attached.

Relationships

related to 0001822 resolvedhenry erased refinement history files for reconstructParMesh with dynamicFvMesh 

Activities

wyldckat

2015-09-27 20:50

updater   ~0005371

Will be fixed along with #1822.

user1210

2015-09-27 21:25

  ~0005373

This report is different than the issue #1822;

#1822: Celllevel and pointlevel can be decomposed and used in parallel. The only problem is that they cannot be reconstructed.

#1855: refinementHistory cannot be decomposed at all. Therefore you lose the history in parallel.

wyldckat

2015-09-27 21:29

updater   ~0005374

Thanks for the clarification! Resetting the Status to "New".

wyldckat

2015-10-27 15:34

updater   ~0005504

For future reference for fixing this issue, it seems that the following commit on the OpenFOAM-History repository has the fix for this, or at least part of the fix: https://github.com/OpenCFD/OpenFOAM-history/commit/af7a439fc7a4f5b03d5f5bf65399a46888f3d164

Issue History

Date Modified Username Field Change
2015-09-26 13:48 user1210 New Issue
2015-09-27 20:48 wyldckat Relationship added duplicate of 0001822
2015-09-27 20:50 wyldckat Note Added: 0005371
2015-09-27 20:50 wyldckat Status new => closed
2015-09-27 20:50 wyldckat Resolution open => duplicate
2015-09-27 21:25 user1210 Note Added: 0005373
2015-09-27 21:25 user1210 Status closed => feedback
2015-09-27 21:25 user1210 Resolution duplicate => reopened
2015-09-27 21:29 wyldckat Note Added: 0005374
2015-09-27 21:29 wyldckat Status feedback => new
2015-09-28 10:46 wyldckat Relationship deleted 0001822
2015-09-28 10:47 wyldckat Relationship added related to 0001822
2015-10-27 15:34 wyldckat Note Added: 0005504