View Issue Details

IDProjectCategoryView StatusLast Update
0001822OpenFOAM[All Projects] Bugpublic2016-06-11 16:51
Reporteruser1210Assigned Tohenry 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Versiondev 
Summary0001822: erased refinement history files for reconstructParMesh with dynamicFvMesh
DescriptionAny *DyMFoam solver stores the refinement history files (cellLevel, pointLevel, refinementHistory). If the case is run in parallel for dynamic refinement, then this files cannot be reconstructed with the command "reconstructParMesh".

This is problematic, if the reconstructed case is decomposed and run again. It re-refines the already refined cells since there exists no refinement history files.

Modifications to reconstructParMesh command are required in order to correctly reconstruct the refinement related files.
Steps To ReproduceTake any *DyMFoam solver;
1)decomposePar
2)run solver
3)reconstructParMesh
4)reconstructPar
5)decomposePar
6)run solver again starting from latestTime.

Observation: the cells, which were refined during (2), are refined again in (6).
TagsNo tags attached.

Relationships

has duplicate 0002011 closedwyldckat Restart Parallel Case with dynamicRefineFvMesh does not work 
related to 0001855 new decomposePar+refinementHistory doesn't work 

Activities

wyldckat

2015-08-11 23:41

updater   ~0005222

If I remember correctly, dynamic meshes are reconstructed using "reconstructPar".
The utility "reconstructParMesh" was designed for reconstructing static meshes.

Can you please let us know if not using step #3 ( "3)reconstructParMesh" ) on your list solves the problem?

user1210

2015-08-12 12:41

  ~0005223

Thanks for your reply. Unfortunately, reconstructPar is not working with the refinement enabled cases. Because, each saved time has different mesh file in processor folder and "pointProcAddressing" is missing if you want to run reconstructPar. Therefore, it is a must to run reconstructParMesh to create mesh folders.

wyldckat

2015-09-27 20:50

updater   ~0005370

Quoting alpalbayrak from #1855:
«For any *DyMFoam solver, decomposePar is not working for refinementHistory file, which is stored in polyMesh folder in time folders. This disables the unrefinement process in parallel run.»

MattijsJ

2016-06-10 11:56

reporter   ~0006421

Fixed in merge 1441f8cab064a79b65e0dc7c80e86b8c45dc2f80 (in dev) from the OpenFOAM-history repo, in particular:

    decomposePar: clean up decomposition of refinement data from snappyHexMesh

    reconstructPar: reconstruct refinement data (refineHexMesh, snappyHexMesh)

    reconstructParMesh: reconstruct refinement data (refineHexMesh, snappyHexMesh)

henry

2016-06-11 16:51

manager   ~0006433

Resolved in OpenFOAM-dev by commit 1441f8cab064a79b65e0dc7c80e86b8c45dc2f80

Issue History

Date Modified Username Field Change
2015-08-10 23:59 user1210 New Issue
2015-08-11 23:41 wyldckat Note Added: 0005222
2015-08-12 12:41 user1210 Note Added: 0005223
2015-09-27 20:48 wyldckat Relationship added has duplicate 0001855
2015-09-27 20:50 wyldckat Note Added: 0005370
2015-09-28 10:46 wyldckat Relationship deleted has duplicate 0001855
2015-09-28 10:47 wyldckat Relationship added related to 0001855
2016-03-01 13:27 wyldckat Relationship added has duplicate 0002011
2016-06-10 11:56 MattijsJ Note Added: 0006421
2016-06-11 16:51 henry Note Added: 0006433
2016-06-11 16:51 henry Status new => resolved
2016-06-11 16:51 henry Fixed in Version => dev
2016-06-11 16:51 henry Resolution open => fixed
2016-06-11 16:51 henry Assigned To => henry