View Issue Details

IDProjectCategoryView StatusLast Update
0000885OpenFOAM[All Projects] Bugpublic2015-02-24 17:00
Reporteruser676Assigned Tohenry 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000885: RotorDiskSource affected by cylindricalCS bug previously reported 2012-12-21 and other specific bug
DescriptionThe new source implemented into Openfoam "RotorDisk" accept as true that correct cylindrical transformation is applied over vector fields using cylindricalCS tool.

http://www.openfoam.org/mantisbt/view.php?id=708#bugnotes

That transformation is valid for points but not for vector fields.

Apart from that bug already known, this source is "valid" only for propellers but not for wind turbines.
Steps To ReproduceWind Turbine modelled
Additional Informationvector localForce = vector(0.0, -f*Cd, tipFactor*f*Cl); //ORIGINAL

It is needed to project Cd and Cl ( obtained from polar curves) taking into account the angle of attack "alphaEff". When alphaEff is too small, the cosine is almost one and the approximation may be valid. In the case of helicopters for example the major force contribution is normal to the rotor plane, but when dealing with windmill, it is needed to take into account also the swirl due to the lift component.
So if I am correct:
-f*Cd ====> -f*Cd*cos(alphaEff)+tipFactor*f*Cl*sin(alphaEff)
tipFactor*f*Cl======>tipFactor*f*Cl*cos(alphaEff)+f*Cd*sin(alphaEff)
 
TagscylindricalCS

Activities

wyldckat

2015-02-14 21:41

updater   ~0003773

The related bug report #708 was fixed last year: http://www.openfoam.org/mantisbt/view.php?id=708

Is this bug report still applicable or was it fixed as well back then?

henry

2015-02-24 16:59

manager   ~0003887

Fixed in OpenFOAM-2.3.x

Issue History

Date Modified Username Field Change
2013-06-11 16:48 user676 New Issue
2015-02-14 21:36 wyldckat Tag Attached: cylindricalCS
2015-02-14 21:41 wyldckat Note Added: 0003773
2015-02-24 16:59 henry Note Added: 0003887
2015-02-24 16:59 henry Status new => resolved
2015-02-24 16:59 henry Resolution open => fixed
2015-02-24 16:59 henry Assigned To => henry