View Issue Details

IDProjectCategoryView StatusLast Update
0000868ThirdParty[All Projects] Bugpublic2015-05-17 09:29
ReporterroenbyAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version 
Fixed in Version 
Summary0000868: Wrong path when compiling paraview with mpi support
DescriptionProblem:

After executing OpenFOAM-2.2.0/Allwmake an attempt to compile paraview with:

cd $WM_THIRD_PARTY_DIR
./makeParaView -mpi -python > makeParaview.log 2>&1

stopped due to:

make[2]: *** No rule to make target `/home/dhi/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc/openmpi-1.6.3/lib/libmpi.so', needed by `bin/libMapReduceMPI.so.pv3.12'. Stop.

Solution:

Inspection of the mpi directories revealed that "lib" should be "lib64".

The problem was solved by replacing $MPI_ARCH_PATH/lib by $MPI_ARCH_PATH/lib64 in the file

ThirdParty-2.2.0/etc/tools/makeParaView

Cheers,

Johan
TagsNo tags attached.

Activities

wyldckat

2015-05-17 00:38

updater   ~0004761

This was fixed in #1549: http://www.openfoam.org/mantisbt/view.php?id=1549

henry

2015-05-17 09:29

manager   ~0004764

Resolved by #1549: http://www.openfoam.org/mantisbt/view.php?id=1549

Issue History

Date Modified Username Field Change
2013-05-23 09:52 roenby New Issue
2015-05-17 00:38 wyldckat Note Added: 0004761
2015-05-17 09:29 henry Note Added: 0004764
2015-05-17 09:29 henry Status new => resolved
2015-05-17 09:29 henry Resolution open => fixed
2015-05-17 09:29 henry Assigned To => henry