View Issue Details

IDProjectCategoryView StatusLast Update
0000864OpenFOAM[All Projects] Bugpublic2014-02-18 09:00
ReporterjacobAssigned Touser2 
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version 
Fixed in Version 
Summary0000864: cyclicAMIPolyPatch::findFaceMaxRadius computes wrong rotation
DescriptionThe function cyclicAMIPolyPatch::findFaceMaxRadius is used to compute rotational displacement between two cyclicAMI patches. However, the algorithm is unsuitable for more complex wedge-like geometries.

On both patches the algorithm chooses the face that is most distant from the rotation axis. Generally, the chosen faces do not correspond (i.e. their coordinate along the axis may differ significantly). If the (radially) far edges of the AMI surfaces are parallel with the axis of rotation, it doesn't matter. But if those edges are not parallel with the axis of rotation, the resulting computed rotational displacement is wrong and AMI crashes.
TagsNo tags attached.

Relationships

duplicate of 0000585 resolveduser2 Failure to initialize cyclicAMI 

Activities

jacob

2013-06-12 15:36

reporter   ~0002276

Last edited: 2013-06-12 15:37

View 2 revisions

Actually, it would be easiest to let the user specify the requested angular displacement between the cyclicAMI patches on his/her own.

jacob

2013-09-30 14:48

reporter   ~0002523

This is actually a duplicate of http://www.openfoam.org/mantisbt/view.php?id=585 .

user2

2014-02-18 09:00

  ~0002832

Updated in version 2.3.x

Issue History

Date Modified Username Field Change
2013-05-21 14:01 jacob New Issue
2013-06-12 15:36 jacob Note Added: 0002276
2013-06-12 15:37 jacob Note Edited: 0002276 View Revisions
2013-09-30 14:48 jacob Note Added: 0002523
2014-02-18 08:59 user2 Relationship added duplicate of 0000585
2014-02-18 09:00 user2 Note Added: 0002832
2014-02-18 09:00 user2 Status new => closed
2014-02-18 09:00 user2 Assigned To => user2
2014-02-18 09:00 user2 Resolution open => fixed
2014-02-18 09:00 user2 Fixed in Version => 2.3.x