View Issue Details

IDProjectCategoryView StatusLast Update
0000860OpenFOAM[All Projects] Bugpublic2014-12-29 17:32
Reporteruser662Assigned Tohenry 
PrioritylowSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000860: Erroneous description of atmBoundaryLayerInletVelocityFvPatchVectorField in Doxygen
DescriptionIn the description of atmBoundaryLayerInletVelocityFvPatchVectorField in Doxygen it is stated that the property 'z' is a 'vertical co-ordinate [m]'. This property should be (as far as I understand) the direction of the z-coordinate. This is also stated in atmBoundaryLayerInletVelocity/atmBoundaryLayerInletVelocityFvPatchVectorField.H.

Because of this, the example in Doxygen also fails to run as z should be a vector:

myPatch
    {
        type atmBoundaryLayerInletVelocity;
        n (0 1 0);
        z 1.0;
        kappa 0.41;
        Uref 1.0;
        Href 0.0;
        z0 uniform 0.0;
        zGround uniform 0.0;
    }
TagsNo tags attached.

Activities

user662

2013-05-21 09:53

  ~0002223

There is also a small typo in the description of Zg: vlaue -> value

user662

2013-05-22 12:52

  ~0002231

And of course this originates from the file atmBoundaryLayerInletVelocityFvPatchVectorField.H

henry

2014-12-29 17:32

manager   ~0003408

Resolved by commit 278819d0ef6b301f698f66aa00605c687c702a5d

Note that I have renamed Href -> Zref so that the implementation and documentation are more consistent rather than apparently written with the purpose of confusing the user.

Issue History

Date Modified Username Field Change
2013-05-21 09:34 user662 New Issue
2013-05-21 09:53 user662 Note Added: 0002223
2013-05-22 12:52 user662 Note Added: 0002231
2014-12-29 17:32 henry Note Added: 0003408
2014-12-29 17:32 henry Status new => resolved
2014-12-29 17:32 henry Resolution open => fixed
2014-12-29 17:32 henry Assigned To => henry