View Issue Details

IDProjectCategoryView StatusLast Update
0000086OpenFOAM[All Projects] Bugpublic2010-11-23 13:52
Reporteruser82Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformHewlett-Packard clusterOSCent OSOS Version10.04
Product Version 
Fixed in Version 
Summary0000086: Wrong temperature distribution in Ranque-Hilsch vortex tube
DescriptionI use sonicFoam solver for simulating energy separation in Ranque-Hilsch vortex tube. Air flow is supersonic.
Now I have good solution for velocities and pressures. But temperature instead of separating in hot and cold flows decreases all over the domain.
It means solver gives wrong energy distribution.
I think this problem may be in Energy Equation because
it is a transport equation for static energy, not total energy.
May be changing static energy equation on total energy equation will fix this problem.
Steps To ReproduceI tried to correct eEqu.H file in my sonicFoam solver.

{
volScalarField u2 = 0.5 * magSqr(U);

    fvScalarMatrix hEqn
    (
        fvm::ddt(rho, e)
      + fvc::ddt(rho, u2)
      + fvm::div(phi, e)
      + fvc::div(phi, u2)
      ==
        fvc::ddt(p)
    );

    solve(hEqn);
    thermo.correct();
}

Also I tried some another equations, but it did not give adequate results.
TagsNo tags attached.

Activities

henry

2010-11-23 13:52

manager   ~0000133

For some purposes static energy is the preferred choice, particularly in pressure-based solvers. We have solving for total energy in sonicFoam but while this gave improvement in simple cases it caused problems in more complex cases.

If your case required the use of total energy is likely that rhoCentralFoam will be more appropriate than sonicFoam.

Issue History

Date Modified Username Field Change
2010-11-23 13:42 user82 New Issue
2010-11-23 13:52 henry Note Added: 0000133
2010-11-23 13:52 henry Status new => resolved
2010-11-23 13:52 henry Resolution open => fixed
2010-11-23 13:52 henry Assigned To => henry