View Issue Details

IDProjectCategoryView StatusLast Update
0000677OpenFOAM[All Projects] Bugpublic2015-02-04 06:23
Reporteruser536Assigned Touser4 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuseOS Version11.1
Product Version 
Fixed in Version 
Summary0000677: implementation of dynamicmesh in reactingFoam:crash
DescriptionI've been trying to work with dynamic meshes in reactingFoam and I got the following error that crashes my simulation:

Courant Number mean: 0.0994095 max: 0.314101
deltaT = 3.11011e-05
Time = 0.00020706

Selected 40 cells for refinement out of 4000.
Refined from 4000 to 4280 cells.
#0 Foam::error::printStack(Foam::Ostream&) in "/home/ku47897/OpenFOAM/OpenFOAM-2.1.y/platforms/linux64GccDPOpt/lib/libOpenFOAM.so"
#1 Foam::sigSegv::sigHandler(int) in "/home/ku47897/OpenFOAM/OpenFOAM-2.1.y/platforms/linux64GccDPOpt/lib/libOpenFOAM.so"
#2 ?? in "/lib64/libc.so.6"
#3 Foam::dynamicRefineFvMesh::refine(Foam::List<int> const&) in "/home/ku47897/OpenFOAM/OpenFOAM-2.1.y/platforms/linux64GccDPOpt/lib/libdynamicFvMesh.so"
#4 Foam::dynamicRefineFvMesh::update() in "/home/ku47897/OpenFOAM/OpenFOAM-2.1.y/platforms/linux64GccDPOpt/lib/libdynamicFvMesh.so"
#5 main in "/home/ku47897/OpenFOAM/ku47897-2.1.y/platforms/linux64GccDPOpt/bin/reactingFoamDynamic"
#6 __libc_start_main in "/lib64/libc.so.6"
#7 _start at /usr/src/packages/BUILD/glibc-2.9/csu/../sysdeps/x86_64/elf/start.S:116
Segmentation fault
Steps To Reproduce1. Compile the attached solver reactingFoamDynamicmesh
2. Run reactingFoamDynamicmesh in case counterFlowFlame2D
TagsNo tags attached.

Activities

user536

2012-11-05 07:46

 

reactingFoamDynamicMesh.tgz (7,565 bytes)

nogenmyr

2012-11-07 16:47

reporter   ~0001768

Seem to be the same as these:

http://www.openfoam.org/mantisbt/view.php?id=637

http://www.openfoam.org/mantisbt/view.php?id=459

user536

2012-11-08 18:28

  ~0001769

nogenmyr,thank you!
I have rectified the code as suggested and tried again. but the same crash still exists.

nogenmyr

2012-11-09 06:21

reporter   ~0001770

Do you use a recent version of 2.1.x? I would not advice you to use the fix in bug report 459. The issue should have been resolved by commit b8bf0e8d02b022fab30068b760fdf44c8f847e96 as stated in report 637. If that fix do not work please report here!

user536

2012-11-09 09:19

  ~0001771

Yes, I downloaded 2.1.x this monday and installed again. First I used the solver in my attached files but failed. Then I checked ODEChemistryModel, and committed as suggested in 637. Still failed. the crash informations are same.
Would you like to try the solver and case in attached files? Thank you very much.

nogenmyr

2012-11-09 18:10

reporter   ~0001772

Oh, now I realize this has nothing to do with the bug reports I referred to. Sorry for the confusion. Your problem is that you are applying refinement, which is a pure 3D feature in that it splits hex cells in all directions, to a 2D case. You can do this, but you have to use symmetryPlane instead of empty, and at a significantly higher CPU cost due to 3D problem.

user536

2012-11-09 23:02

  ~0001773

Oh,I see. But I changed the attched case to one 3D one. But the crash still happened.

the crash information is as follows.
Selected 20 cells for refinement out of 24000.
Refined from 24000 to 24140 cells.
Selected 0 split points out of a possible 20.
diagonal: Solving for rho, Initial residual = 0, Final residual = 0, No Iterations 0
#0 Foam::error::printStack(Foam::Ostream&)^C

user4

2015-02-04 06:23

  ~0003668

Works fine in 2.1.x.

Issue History

Date Modified Username Field Change
2012-11-05 07:46 user536 New Issue
2012-11-05 07:46 user536 File Added: reactingFoamDynamicMesh.tgz
2012-11-07 16:47 nogenmyr Note Added: 0001768
2012-11-08 18:28 user536 Note Added: 0001769
2012-11-09 06:21 nogenmyr Note Added: 0001770
2012-11-09 09:19 user536 Note Added: 0001771
2012-11-09 18:10 nogenmyr Note Added: 0001772
2012-11-09 23:02 user536 Note Added: 0001773
2015-02-04 06:23 user4 Note Added: 0003668
2015-02-04 06:23 user4 Status new => resolved
2015-02-04 06:23 user4 Fixed in Version => 2.1.x
2015-02-04 06:23 user4 Resolution open => fixed
2015-02-04 06:23 user4 Assigned To => user4