View Issue Details

IDProjectCategoryView StatusLast Update
0000066OpenFOAM[All Projects] Bugpublic2010-10-26 17:08
Reporteruser25Assigned Touser2 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionsuspended 
PlatformLinuxOSFedoraOS Version12
Product Version 
Fixed in Version 
Summary0000066: Temperature increases beyond inlet temperatures with reactions off
DescriptionSolved for only species transport, the CounterflowFlame2D tutorial file (in version 1.7.1) using reactingFoam.
Specified reactions off and turbulent reactions off in constant/chemistryProperties.
Temperatures at both inlets are 800K (as was given in the tutorial file). No other modificattion in the files.
As no reactions, one would expect temperatures to be below 800K as only species transport.
However, the temperature increased beyond 800 K (it went close to 840 K - log file is attached).
Why temperatures should increase if there is no heat generation due to reaction?
TagsNo tags attached.

Activities

user25

2010-10-26 08:16

 

log.rar (315,096 bytes)

user2

2010-10-26 17:08

  ~0000094

Our reactingFoam algorithm is an efficient, approximate method for turbulent reacting flow. However, in the laminar limit the approximation breaks down, leading to temperature inconsistencies.

In the laminar case, if you have a composition gradient, the only way to ensure that the diffusion does not give rise to temperature errors is by enforcing a Lewis no = 1 constraint, e.g. update the sensible enthalpy eqn to:

    fvScalarMatrix hsEqn
    (
        fvm::ddt(rho, hs)
      + mvConvection->fvmDiv(phi, hs)
// - fvm::laplacian(turbulence->alphaEff(), hs)
      - fvm::laplacian(turbulence->muEff(), hs) // unit lewis no.
     ==
        DpDt
      + chemistrySh
    );

This is an area that we would like to research and update in the future if we gain sponsorship to do so.

Issue History

Date Modified Username Field Change
2010-10-26 08:16 user25 New Issue
2010-10-26 08:16 user25 File Added: log.rar
2010-10-26 09:15 user2 Priority urgent => normal
2010-10-26 09:16 user2 Assigned To => user2
2010-10-26 09:16 user2 Status new => assigned
2010-10-26 17:08 user2 Note Added: 0000094
2010-10-26 17:08 user2 Status assigned => resolved
2010-10-26 17:08 user2 Resolution open => suspended