View Issue Details

IDProjectCategoryView StatusLast Update
0000639OpenFOAM[All Projects] Bugpublic2015-02-05 10:11
ReporterdhoraAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000639: Wall distance across non-matching AMI
DescriptionWall distance across non-matching AMI is not correct. Not sure if it's a bug or just not supported.
Steps To ReproduceTest case (5 MB) can be provided if requested.
TagsAMI

Activities

dhora

2012-08-30 10:28

reporter  

AMI_bug.pdf (27,725 bytes)

user4

2012-08-30 10:37

  ~0001646

It should work, there is no distinction between 1:1 matching and non-1:1 matching in AMI, they all are just using an interpolated value (based on the area overlap).

What are your weights min and max and average?

Can you set up a tiny case that demonstrates the problem?

Mattijs

user4

2012-08-30 18:20

  ~0001654

The problem is that the functions to make the nearest wall point relative are not reciprocal so accumulate errors.

I'll push a workaround 5ecafe8a5e035a55781a3b62a7870b585daaf0ed which for collocated AMI does not use these functions and will have a think about how to solve it in general.

henry

2015-02-05 10:11

manager   ~0003688

More accurate wall distance fields may be obtained using the Poisson or advectionDiffusion methods which will operate across AMIs in the same manner as solving for any FV field.

Issue History

Date Modified Username Field Change
2012-08-30 10:28 dhora New Issue
2012-08-30 10:28 dhora File Added: AMI_bug.pdf
2012-08-30 10:37 user4 Note Added: 0001646
2012-08-30 18:20 user4 Note Added: 0001654
2014-12-29 18:42 wyldckat Tag Attached: AMI
2015-02-05 10:11 henry Note Added: 0003688
2015-02-05 10:11 henry Status new => resolved
2015-02-05 10:11 henry Resolution open => fixed
2015-02-05 10:11 henry Assigned To => henry