View Issue Details

IDProjectCategoryView StatusLast Update
0000613ThirdParty[All Projects] Bugpublic2015-01-18 19:09
ReporterwyldckatAssigned Tohenry 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000613: MPICH2 can't handle "make -j 2" or more
DescriptionIt has recently come to my attention that MPICH2 is unable to handle parallel builds of it's own source code.
The reason is described here: http://trac.mcs.anl.gov/projects/mpich2/ticket/170

This apparently has been fixed with the release of MPICH2 1.5a1: http://wiki.mcs.anl.gov/mpich2/index.php/Frequently_Asked_Questions#Q:_The_build_fails_when_I_use_parallel_make.

Therefore, I suggest that at least a comment is placed at "ThirdParty-2.1.x/Allwmake", for MPICH2's; perhaps something like this:

  # Uncomment for MPICH2 1.5a1 or above
  #make -j $WM_NCOMPPROCS && make install

  # For MPICH2 below 1.5a1. Comment the line otherwise
  make && make install
Steps To Reproduce1. Use a multi-core machine.
2. Use WM_MPLIB=MPICH and unpack the source code for the respectively defined version.
3. Define WM_NCOMPPROCS with a value larger than 1 in the shell environment.
4. Run Allwmake in the ThirdParty folder.

Odds are MPICH2 will not build successfully.
Additional InformationThe thread where I discovered this issue: http://www.cfd-online.com/Forums/openfoam-installation/105357-openfoam210-compilation-error-mpicxx-h-file.html

And my apologies, because several months ago I think I was the one (or one of) that reported about using -j for building the MPIs...


Last but not least: I haven't compared performances between the latest Open-MPI and MPICH2 versions, so I don't know if there is any benefit in using MPICH2.
TagsNo tags attached.

Activities

wyldckat

2015-01-18 10:53

updater   ~0003557

I believe this issue still stands and the proposed fix is still applicable.
The updated link to the FAQ is this one: https://wiki.mpich.org/mpich/index.php/Frequently_Asked_Questions#Q:_The_build_fails_when_I_use_parallel_make.

henry

2015-01-18 19:09

manager   ~0003558

Resolved by commit 95f52d790fc9ea6c851cbea1f4f7b4de208bdf59

Issue History

Date Modified Username Field Change
2012-08-03 15:03 wyldckat New Issue
2015-01-18 10:53 wyldckat Note Added: 0003557
2015-01-18 19:09 henry Note Added: 0003558
2015-01-18 19:09 henry Status new => resolved
2015-01-18 19:09 henry Resolution open => fixed
2015-01-18 19:09 henry Assigned To => henry