View Issue Details

IDProjectCategoryView StatusLast Update
0000612OpenFOAM[All Projects] Bugpublic2012-08-13 10:51
ReporterwyldckatAssigned Touser2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000612: "paraFoam -builtin" indicates that it requires the official plugin
DescriptionI've found this several months ago, but I kept forgetting about reporting this issue.
The fix is very simple: the "-builtin" option should set "requirePV=0" as well, as shown in the "Steps To Reproduce" below.
Steps To Reproducediff --git a/bin/paraFoam b/bin/paraFoam
index 867212e..e6465f0 100755
--- a/bin/paraFoam
+++ b/bin/paraFoam
@@ -85,6 +85,7 @@ do
         ;;
     -builtin)
         extension=foam
+ requirePV=0
         shift
         ;;
     -case)
Additional InformationRelated hint/suggestion for the next OpenFOAM release(s) - ParaView development packages are already supplied in some of the major Linux distributions:
* Ubuntu - paraview-dev
* Fedora - paraview-devel

Although since ParaView versions evolve with each release for each Linux distribution... it would possibly require that OpenFOAM's own plug-in individually evolved as well along with each distribution's ParaView version.
TagsNo tags attached.

Activities

user2

2012-08-13 10:51

  ~0001586

Thanks for the report - resolved by commit a551091

Issue History

Date Modified Username Field Change
2012-08-02 21:18 wyldckat New Issue
2012-08-13 10:51 user2 Note Added: 0001586
2012-08-13 10:51 user2 Status new => resolved
2012-08-13 10:51 user2 Fixed in Version => 2.1.x
2012-08-13 10:51 user2 Resolution open => fixed
2012-08-13 10:51 user2 Assigned To => user2