View Issue Details

IDProjectCategoryView StatusLast Update
0000611OpenFOAM[All Projects] Bugpublic2012-08-02 17:01
Reporteruser487Assigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSCentOSOS Version5.2
Product Version 
Fixed in Version 
Summary0000611: fvSchemes::divSchemes does not accept a default input and run
DescriptionThe fvSchemes::divSchemes sub-dictionary reads:

divSchemes
{
    default Gauss upwind;
}

When I run buoyantBoussinesqSimpleFoam, the follow error occurs:


Starting time loop

Time = 1



--> FOAM FATAL IO ERROR:
attempt to read beyond EOF

file: /home/leonard/OpenFOAM/sgr/testing/makeCase.20120802.113907/system/fvSchemes::divSchemes::default at line 6.

    From function ITstream::read(token&)
    in file db/IOstreams/Tstreams/ITstream.C at line 83.

FOAM exiting


There appears to be something awry with this.
TagsNo tags attached.

Activities

henry

2012-08-02 17:01

manager   ~0001541

Using "Gauss upwind" as the default "div" scheme would be crazy as it is totally inappropriate for non-advective terms (i.e. those terms not using a flux) and it is these terms generating the error because you have not provided the name of the flux field they should with which they should judge "upwind".

Issue History

Date Modified Username Field Change
2012-08-02 16:49 user487 New Issue
2012-08-02 17:01 henry Note Added: 0001541
2012-08-02 17:01 henry Status new => resolved
2012-08-02 17:01 henry Resolution open => no change required
2012-08-02 17:01 henry Assigned To => henry