View Issue Details

IDProjectCategoryView StatusLast Update
0000590OpenFOAM[All Projects] Bugpublic2012-07-25 10:04
Reporteruser476Assigned Tohenry 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSCentOSOS Version5.5
Product Version 
Fixed in Version 
Summary0000590: snappyhexmesh compiled with intel compiler crashes when run parallel
Descriptionsnappyhexmesh compiled with intel compiler crashes when run parallel right after "Feature refinement iteration 0" with an Index error ("size x out of range 0 ... y")
Similar issue was reported when snappyHexMesh was compiled with Debug-options crashes when run in parallel - "ID 0000088" and it was marked fixed in the tracker.
TagsNo tags attached.

Activities

wyldckat

2012-07-20 13:11

updater   ~0001477

Last edited: 2012-07-20 13:18

View 2 revisions

I'm curious about this report...
Can you provide more details:
* What ICC version are you using?
* 32 or 64bit?
* Is this issue triggered when using the OpenFOAM tutorials that use "snappyHexMesh" in parallel? If so, which ones?
* (edit) And which MPI library?

user476

2012-07-20 14:06

  ~0001479

The behavior is a bit strange.
64bit version
Try the 'flange' tutorial in shm 2.1.x. Try with this setting:
    --> Use hierarchical decomposition into 4 sub-domains ( 1 1 4 ) and run it.

openmpi 1.5.3

wyldckat

2012-07-21 01:15

updater   ~0001483

I tried to reproduce the error, but wasn't able to do it. Here are the specs of the environment I used for the test:
* AMD 1055T, so I had to disable SS3 in the wmake rules for c++. This implies a rather big difference from using an Intel CPU, given that the optimizations used are different :(

* icc --version
icc (ICC) 12.1.4 20120410
Copyright (C) 1985-2012 Intel Corporation. All rights reserved.
(Non-commercial version for Linux.)

* Couldn't get the flange tutorial to work in parallel from your description, so I went with the tutorial "incompressible/pisoFoam/les/motorBike/motorBike".
In "snappyHexMeshDict" I had to reduce the surface refinement level from "6 8" to "5 7", due to insufficient memory (only have around 6 GB).
Then simply ran Allrun; after snappyHexMesh completed, I aborted execution. The "log.snappyHexMesh" file showed no errors and there was no crash. Took 319s to complete.

Personally I won't be able to test this with an Intel CPU, so try to use the same tutorial I used to check if the same issue occurs.

user476

2012-07-21 12:47

  ~0001484

Last edited: 2012-07-21 12:49

View 2 revisions

I compiled OF2.1.0 in DEBUG mode using gcc version 4.4.5 on Ubuntu and i ran the motorbike snappyhexmesh case in parallel...and it failed.
--> Use hierarchical decomposition into 2 sub-domains ( 1 1 2 ) and run it.
It fails at "Surface refinement iteration 1".

Please try this and let me know what happens.

wyldckat

2012-07-22 12:56

updater  

motorBike_21x_parallel_hierarchical.tar.gz (8,013 bytes)

wyldckat

2012-07-22 12:56

updater  

motorBike_21x_parallel_ptscotch.tar.gz (8,000 bytes)

wyldckat

2012-07-22 13:00

updater   ~0001485

Last edited: 2012-07-22 13:00

View 2 revisions

I've been unable to reproduce the errors you're getting.

I've attached 2 test cases, one using scotch/ptscotch for decomposition/sHM and another with scotch/hierarchical. Both have worked with Gcc and Icc on my AMD machine.

Do these 2 work for you? Or do both crash?

Don't forget that to use them, run:
  ./Allrun

user476

2012-07-22 14:52

 

log.snappyHexMesh (19,800 bytes)

user476

2012-07-22 14:55

  ~0001486

I dloaded 'motorBike_21x_parallel_hierarchical.tar.gz' and ran it using Allrun, It failed. (Ran using OF2.1.0 compiled in DEBUG mode).
I've attached the snappyhexmesh log file.
My machine is an Intel. Now i'm starting to doubt if its about AMD vs Intel .

wyldckat

2012-07-22 19:07

updater   ~0001488

Last edited: 2012-07-22 19:08

View 2 revisions

Well, from issue #88 we already know that the debug version is going to crash either way.
Can you try with your version built with the Intel compiler (non-debug version)?

As for AMD vs Intel: the thing that might be different here would be the SSE3 option that I can't use. The CPU differences shouldn't play much weight in this kind of compilation. But there could be a bug in the SSE3 optimizations made by the Intel compiler!

user4

2012-07-23 14:21

  ~0001491

I've pushed a change to the construction order of the polyPatches. It should no work with DEBUG. Could you try again?

Commit a41115f0953bdb166ca5c09ac4b15638fe3aa75b

user476

2012-07-25 10:01

  ~0001499

Hi mattijs

shm works fine now with your commit.(debug mode)

Issue History

Date Modified Username Field Change
2012-07-20 12:26 user476 New Issue
2012-07-20 13:11 wyldckat Note Added: 0001477
2012-07-20 13:18 wyldckat Note Edited: 0001477 View Revisions
2012-07-20 14:06 user476 Note Added: 0001479
2012-07-21 01:15 wyldckat Note Added: 0001483
2012-07-21 12:47 user476 Note Added: 0001484
2012-07-21 12:49 user476 Note Edited: 0001484 View Revisions
2012-07-22 12:56 wyldckat File Added: motorBike_21x_parallel_hierarchical.tar.gz
2012-07-22 12:56 wyldckat File Added: motorBike_21x_parallel_ptscotch.tar.gz
2012-07-22 13:00 wyldckat Note Added: 0001485
2012-07-22 13:00 wyldckat Note Edited: 0001485 View Revisions
2012-07-22 14:52 user476 File Added: log.snappyHexMesh
2012-07-22 14:55 user476 Note Added: 0001486
2012-07-22 19:07 wyldckat Note Added: 0001488
2012-07-22 19:08 wyldckat Note Edited: 0001488 View Revisions
2012-07-23 14:21 user4 Note Added: 0001491
2012-07-25 10:01 user476 Note Added: 0001499
2012-07-25 10:04 henry Status new => closed
2012-07-25 10:04 henry Assigned To => henry
2012-07-25 10:04 henry Resolution open => fixed