View Issue Details

IDProjectCategoryView StatusLast Update
0000058OpenFOAM[All Projects] Bugpublic2010-10-18 10:54
Reporteruser55Assigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSKubuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000058: Possible bug in the definition of object nut
DescriptionUsing the turbulence Model LienLeschzinerLowRe leads to this error:


--> FOAM FATAL ERROR:

    request for volScalarField nut from objectRegistry region0 failed
    available objects of type volScalarField are

13
(
pPrevIter
(1-(0.3*exp(-sqr((sqr(k)|(nu*epsilon))))))
k
nu
p
RASModel::G
(symm(grad(U))&&grad(U))
((1-exp((-Am*(((sqrt(k)*y)|nu)+1e-15))))|((1-exp((-Aepsilon*(((sqrt(k)*y)|nu)+1e-15))))+1e-15))
(sqr(k)|(nu*epsilon))
(((sqrt(k)*y)|nu)+1e-15)
(((C2*(1-(0.3*exp(-sqr((sqr(k)|(nu*epsilon)))))))*epsilon)|k)
epsilon
y
)
Additional InformationI looked in the corresponding code files and found that the object nut is defined like this:

  nut_
    (
        IOobject
        (
            "epsilon",
            runTime_.timeName(),
            mesh_,
            IOobject::NO_READ,
            IOobject::AUTO_WRITE
        ),
        autoCreateLowReNut("nut", mesh_)
    )

Please check whether this is the reason for the error.
TagsNo tags attached.

Activities

henry

2010-10-18 10:54

manager   ~0000082

Thanks for the bug report.

This is now fixed in OpenFOAM-1.7.x
commit 6ed0927a82bef1d134740d3e705874d40fe6d54d

Issue History

Date Modified Username Field Change
2010-10-18 10:29 user55 New Issue
2010-10-18 10:41 henry Assigned To => henry
2010-10-18 10:41 henry Status new => assigned
2010-10-18 10:54 henry Note Added: 0000082
2010-10-18 10:54 henry Status assigned => resolved
2010-10-18 10:54 henry Resolution open => fixed