View Issue Details

IDProjectCategoryView StatusLast Update
0000575OpenFOAM[All Projects] Bugpublic2012-07-25 10:11
Reporteruser467Assigned Touser21 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000575: TKE Production term in SAS model
DescriptionThe TKE production term in the SAS model is formulated as:
volScalarField G(nuSgs_*0.5*S2);
where volScalarField S2(2.0*magSqr(symm(gradU())));


while in the SST model it is formulated as:
volScalarField G("RASModel::G", nut_*S2);
where volScalarField S2(2*magSqr(symm(fvc::grad(U_))));

So, there's an added 0.5 term in the expression for G in the SAS model.

TagsNo tags attached.

Activities

user21

2012-07-11 15:33

  ~0001458

Hi,

Could you provide a reference for that expression?

Thanks

user467

2012-07-11 16:15

  ~0001459

Hii,

I have pasted those expressions from the OpenFOAM documentation website (http://www.openfoam.org/docs/cpp/). The corresponding files are kOmegaSSTSAS.C and kOmegaSST.C.

user467

2012-07-14 01:34

  ~0001462

An additional 0.5 in the P_k term can lead to a lower than usual TKE and hence nu_t. This can cause an additional lowering of nu_t in the SAS model over and above the reduction due to the use of the Von-Karman length scale.

user467

2012-07-22 17:25

  ~0001487

Hii Sergio,
Can you please let me know what you think about this? The production of omega term is also multiplied by a factor of 0.5, and I don't see any reason to have these extra 0.5 factors in the production of k and omega terms.

user21

2012-07-23 10:41

  ~0001489

Hi,

The term has been corrected.

Thanks

user21

2012-07-23 11:19

  ~0001490

This issue was solved in commit 1487331270d068a31cc95ae7eace300ca8944613.

user467

2012-07-23 20:57

  ~0001493

Hii Sergio,

I think the production term of omega need to be changed too. Please have a look at it. The 0.5 present there is extraneous.

user21

2012-07-25 10:11

  ~0001500

Hi,

Thanks for the information. The fix is in commit

8a76456ae2c01faccf31108d2088ac4f93b38a87

Issue History

Date Modified Username Field Change
2012-07-07 20:48 user467 New Issue
2012-07-11 15:33 user21 Note Added: 0001458
2012-07-11 16:15 user467 Note Added: 0001459
2012-07-14 01:34 user467 Note Added: 0001462
2012-07-22 17:25 user467 Note Added: 0001487
2012-07-23 10:41 user21 Note Added: 0001489
2012-07-23 10:41 user21 Status new => resolved
2012-07-23 10:41 user21 Resolution open => fixed
2012-07-23 10:41 user21 Assigned To => user21
2012-07-23 11:19 user21 Note Added: 0001490
2012-07-23 11:19 user21 Status resolved => feedback
2012-07-23 11:19 user21 Resolution fixed => reopened
2012-07-23 11:20 user21 Status feedback => resolved
2012-07-23 11:20 user21 Resolution reopened => fixed
2012-07-23 20:57 user467 Note Added: 0001493
2012-07-23 20:57 user467 Status resolved => feedback
2012-07-23 20:57 user467 Resolution fixed => reopened
2012-07-25 10:11 user21 Note Added: 0001500
2012-07-25 10:11 user21 Status feedback => resolved
2012-07-25 10:11 user21 Resolution reopened => fixed