View Issue Details

IDProjectCategoryView StatusLast Update
0000570OpenFOAM[All Projects] Bugpublic2012-07-02 13:53
Reporteruser19Assigned Touser4 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000570: ptscotchDecomp.C reads from both ptscotchCoeffs and scotchCoeffs
DescriptionThe ptscotchDecomp method reads the writeGraph entry from the ptscotchCoeffs sub-dictionary, all other entries, however, from the scotchCoeffs sub-dictionary. If this is indeed a bug (not so sure myself, some documentation would certainly help here), a simple s/"scotchCoeffs"/"ptscotchCoeffs"/g will do the trick.
TagsNo tags attached.

Activities

user4

2012-07-02 09:45

  ~0001435

Good point. My feeling is that it should read it from scotchCoeffs since ptscotch is basically the same as scotch except runs distributed.

user19

2012-07-02 13:28

  ~0001440

Ok, so then it should rather be s/"ptscotchCoeffs"/"scotchCoeffs"/g, right?

user4

2012-07-02 13:53

  ~0001441

Thanks, changed it to scotchCoeffs in

c8ca4abf72973396ecfb928804fd2e195921ac15

Issue History

Date Modified Username Field Change
2012-07-02 09:05 user19 New Issue
2012-07-02 09:45 user4 Note Added: 0001435
2012-07-02 13:28 user19 Note Added: 0001440
2012-07-02 13:53 user4 Note Added: 0001441
2012-07-02 13:53 user4 Status new => resolved
2012-07-02 13:53 user4 Fixed in Version => 2.1.x
2012-07-02 13:53 user4 Resolution open => fixed
2012-07-02 13:53 user4 Assigned To => user4