View Issue Details

IDProjectCategoryView StatusLast Update
0000551ThirdPartyBugpublic2015-11-18 09:55
Reporteruser447Assigned Touser2 
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu 12.04OS Version12.04
Summary0000551: unable to run paraFoam
DescriptionI recently install ubuntu 12.04, openFoam and Paraview,
I used yesterday for firs time and have no problem in none of openFoam and ParaFoam, but today, paraview dose'nt run and says:
ERROR: In /home/opencfd/OpenFOAM/ThirdParty-2.1.x/ParaView-3.12.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x2435f70): Could not find a decent visual


ERROR: In /home/opencfd/OpenFOAM/ThirdParty-2.1.x/ParaView-3.12.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 629
vtkXOpenGLRenderWindow (0x2435f70): Cannot create GLX context. Aborting.

Aborted (core dumped)
TagsNo tags attached.


related to 0001915 closedwyldckat OpenFOAM paraFoam from tutorial fails while blockMesh and icoFoam work fine 



2012-06-11 07:26


Do you have a OpenGL-capable graphics driver installed? If you install the package mesa-utils and run the program glxinfo, what is the output? Especially, the "OpenGL renderer string" is of interest.


2012-06-11 12:28


In additional drivers, I should install :
ATI/AMD proprietary FGLRX graphics driver (post-release updates)
ATI/AMD proprietary FGLRX graphics driver
the second one is installed but the first one, is not and said that the lof file in /var/log/jockey.log , I should look at


2012-06-11 13:32


thanks for your reply but i do not know how to do it?to install mesa-utils and to get output?


2012-06-11 13:33


No. Like this:

  sudo apt-get install mesa-utils


2012-06-11 14:44


mesa-utils is installed with new version but when i typed in terminal: glxinfo
X Error of failed request: BadRequest (invalid request code or no such operation)
  Major opcode of failed request: 154 (GLX)
  Minor opcode of failed request: 19 (X_GLXQueryServerString)
  Serial number of failed request: 12
  Current serial number in output stream: 12

thank you again


2012-06-11 15:07


thank you a lot
thank you very much
it solved after install mesa-utils.I should restart and then type glxinfo
after that i run paraFoam and it work
thank you


2012-06-11 20:10


Glad to hear the issue could be resolved so easily. However, I have no idea why it worked, though... Could it just be the reboot, and nothing actually to do with mesa-utils?


2012-06-12 04:53


I am not so familiar with linux and openfoam, so I do not what happen, But mesa-utils has not installed in my notebook till yesterday


2012-06-12 08:59


Not an OpenFOAM bug

Issue History

Date Modified Username Field Change
2012-06-11 06:29 user447 New Issue
2012-06-11 07:26 user19 Note Added: 0001369
2012-06-11 12:28 user447 Note Added: 0001373
2012-06-11 13:32 user447 Note Added: 0001374
2012-06-11 13:33 user19 Note Added: 0001375
2012-06-11 14:44 user447 Note Added: 0001378
2012-06-11 15:07 user447 Note Added: 0001379
2012-06-11 20:10 user19 Note Added: 0001381
2012-06-12 04:53 user447 Note Added: 0001382
2012-06-12 08:59 user2 Priority high => normal
2012-06-12 08:59 user2 Severity major => minor
2012-06-12 08:59 user2 Note Added: 0001385
2012-06-12 08:59 user2 Status new => resolved
2012-06-12 08:59 user2 Resolution open => fixed
2012-06-12 08:59 user2 Assigned To => user2
2015-11-18 09:55 wyldckat Relationship added related to 0001915