View Issue Details

IDProjectCategoryView StatusLast Update
0000514OpenFOAM[All Projects] Bugpublic2012-04-18 15:34
Reporteruser415Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
PlatformXeon ClusterOSCentOSOS Version5.x
Product Version 
Fixed in Version 
Summary0000514: time step directory naming error
DescriptionHi
I have experienced naming error when time is over 1.0 sec.

This is a copy from SSH terminal


[c28li@saw-login1 naca0012_10_256d_v4_m2_s1]$ ls processor0
0.01 0.28 0.55 0.82 1.0900000000005896 1.3600000000023584
0.02 0.29 0.56 0.83 1.1000000000006551 1.3700000000024239
0.03 0.3 0.57 0.84 1.1100000000007206 1.3800000000024895
0.04 0.31 0.58 0.85 1.1200000000007861 1.390000000002555
0.05 0.32 0.59 0.86 1.1300000000008517 1.4000000000026205
0.06 0.33 0.6 0.87 1.1400000000009172 1.410000000002686
0.07 0.34 0.61 0.88 1.1500000000009827 1.4200000000027515
0.08 0.35 0.62 0.89 1.1600000000010482 1.430000000002817
0.09 0.36 0.63 0.9 1.1700000000011137 1.440000000003
0.1 0.37 0.64 0.91 1.1800000000011792 1.450000000003
0.11 0.38 0.65 0.92 1.1900000000012447 1.460000000003
0.12 0.39 0.66 0.93 1.2000000000013102 1.470000000003
0.13 0.4 0.67 0.94 1.2100000000013758 1.480000000003
0.14 0.41 0.68 0.95 1.2200000000014413 1.490000000003
0.15 0.42 0.69 0.96 1.2300000000015068 1.500000000003
0.16 0.43 0.7 0.97 1.2400000000015723 1.510000000003
0.17 0.44 0.71 0.98 1.2500000000016378 1.520000000003
0.18 0.45 0.72 0.99 1.2600000000017033 1.530000000003
0.19 0.46 0.73 1 1.2700000000017688 1.540000000004
0.2 0.47 0.74 1.0100000000000655 1.2800000000018343 1.550000000004
0.21 0.48 0.75 1.020000000000131 1.2900000000018998 1.560000000004
0.22 0.49 0.76 1.0300000000001965 1.3000000000019654 1.570000000004
0.23 0.5 0.77 1.040000000000262 1.3100000000020309 1.580000000004
0.24 0.51 0.78 1.0500000000003276 1.3200000000020964 1.590000000004
0.25 0.52 0.79 1.0600000000003931 1.3300000000021619 1.600000000004
0.26 0.53 0.8 1.0700000000004586 1.3400000000022274 constant
0.27 0.54 0.81 1.0800000000005241 1.3500000000022929

I am using ver 2.0.1
Attached is my controlDict

Thank you very much for your time. Please let me know if additional info is needed.

Best Regards,
Tom
Steps To Reproducerun simulation over 1.0 sec
TagsNo tags attached.

Activities

user415

2012-04-18 04:22

 

controlDict (2,312 bytes)
/*--------------------------------*- C++ -*----------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  2.0.1                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.com                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
FoamFile
{
    version     2.0;
    format      ascii;
    class       dictionary;
    location    "system";
    object      controlDict;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //

application     pisoFoam;

startFrom       latestTime;

startTime       1.0;

stopAt          endTime;

endTime         3.0;

deltaT          5e-6;

writeControl    runTime;

writeInterval   0.01;

purgeWrite      0;

writeFormat     ascii;

writePrecision  6;

writeCompression off;

timeFormat      general;

timePrecision   6;

runTimeModifiable true;

maxCo           0.5;

functions
{
    forces
    {
        type            forceCoeffs;
        functionObjectLibs ( "libforces.so" );
        outputControl   timeStep;
        outputInterval  1;

        patches
        (
            AIRFOIL
        );

        pName       p;
        UName       U;
        log         true;
        rhoName rhoInf;
        rhoInf      1.2041;
        CofR        ( 0 0 0 );
        liftDir     ( 0 1 0 );
        dragDir     ( 1 0 0 );
        pitchAxis   ( 0 0 1 );
        magUInf     28.16;
        lRef        0.914;
        Aref        0.0835396;
    }

  /*  wallPressure
    {
        type            surfaces;
        functionObjectLibs ("libsampling.so");
        outputControl   timeStep;
        outputInterval  1;
        surfaceFormat   foamFile;
        interpolationScheme cell;
        fields
        (
            p
        );

        surfaces
        (
            AIRFOIL_WALL
            {
                type        patch;
                patches     (AIRFOIL);
                triangulate false;
            }
        );
    } */
}



// ************************************************************************* //
controlDict (2,312 bytes)

albertop

2012-04-18 05:21

reporter   ~0001264

Hi, this is not a bug, but an incorrect setting in your controlDict.

You are using an adaptive time-stepping with "writeControl runTime;". It should be
"writeControl adjustableRunTime;".

P.S. This is explained in the User's Guide ;-)

user415

2012-04-18 05:32

  ~0001265

Hi

Thanks for your reply. Sorry I am pretty new to openFOAM.
I see in the guide it says the adjustableRunTime is used for cases with automatic time step adjustment.
My question is, even if I don't have the line " adjustTimeStep yes;" does it still do the adjustment? Would it be better if I just turn it off by adding the line " adjustTimeStep no;" instead?

Thanks for your time.

Best Regards
Tom

albertop

2012-04-18 05:37

reporter   ~0001266

It should default to "false" if you do not have the line ( http://foam.sourceforge.net/docs/cpp/a03938_source.html#l00029 ), however you can check directly from your log file to see what the solver is actually doing.

albertop

2012-04-18 05:38

reporter   ~0001267

Also, did you try to reproduce this problem with OpenFOAM 2.1.x?

user415

2012-04-18 05:50

  ~0001268

Hi

Thanks for your reply.
When I check my log this appears after timestep 1.00001


Time = 1.00001

Courant Number mean: 0.00657961 max: 0.698939
DILUPBiCG: Solving for Ux, Initial residual = 4.53454e-06, Final residual = 4.53454e-06, No Iterations 0
DILUPBiCG: Solving for Uy, Initial residual = 9.47834e-06, Final residual = 9.47834e-06, No Iterations 0
DILUPBiCG: Solving for Uz, Initial residual = 6.56565e-06, Final residual = 6.56565e-06, No Iterations 0
DICPCG: Solving for p, Initial residual = 0.00490607, Final residual = 0.000453238, No Iterations 2
time step continuity errors : sum local = 3.65471e-10, global = 3.08417e-13, cumulative = 3.08417e-13
DICPCG: Solving for p, Initial residual = 0.00129323, Final residual = 9.6964e-07, No Iterations 393
time step continuity errors : sum local = 7.82084e-13, global = -2.91727e-15, cumulative = 3.055e-13
DILUPBiCG: Solving for omega, Initial residual = 6.14083e-06, Final residual = 6.14083e-06, No Iterations 0
DILUPBiCG: Solving for k, Initial residual = 8.174e-06, Final residual = 8.174e-06, No Iterations 0
ExecutionTime = 4.45 s ClockTime = 7 s

forceCoeffs output:
    Cd = 0.0571562
    Cl = -1.11777
    Cm = -0.282938

--> FOAM Warning :
    From function Time::operator++()
    in file db/Time/Time.C at line 937
    Increased the timePrecision from 6 to 17 to distinguish between timeNames at time 1.00001
Time = 1.0000100000000001

Courant Number mean: 0.00657961 max: 0.698938
DILUPBiCG: Solving for Ux, Initial residual = 4.76721e-06, Final residual = 4.76721e-06, No Iterations 0
DILUPBiCG: Solving for Uy, Initial residual = 1.00906e-05, Final residual = 5.20755e-10, No Iterations 1
DILUPBiCG: Solving for Uz, Initial residual = 1.80269e-05, Final residual = 1.4854e-09, No Iterations 1
DICPCG: Solving for p, Initial residual = 0.00600079, Final residual = 0.000381914, No Iterations 3
time step continuity errors : sum local = 3.0789e-10, global = 1.94607e-12, cumulative = 2.25157e-12
DICPCG: Solving for p, Initial residual = 0.00152424, Final residual = 9.95328e-07, No Iterations 405
time step continuity errors : sum local = 8.02255e-13, global = -2.4823e-15, cumulative = 2.24909e-12
DILUPBiCG: Solving for omega, Initial residual = 6.14084e-06, Final residual = 6.14084e-06, No Iterations 0
DILUPBiCG: Solving for k, Initial residual = 8.17437e-06, Final residual = 8.17437e-06, No Iterations 0
ExecutionTime = 5.3 s ClockTime = 8 s

forceCoeffs output:
    Cd = 0.0572613
    Cl = -1.11859
    Cm = -0.283292

Is this change in time precision fixable by changing writeControl to adjustableRunTime?

Btw I do not have OpenFOAM 2.1.x installed in the cluster (it takes a lot of work to get the support person to install a newer version).

Thanks,
Tom

albertop

2012-04-18 06:00

reporter   ~0001269

Apparently your time-step changed from 1.0e-6 to 1.0e-17, if you compare the two times you reported.

henry

2012-04-18 07:48

manager   ~0001271

It looks like your case is blowing-up and the time-step is too small to continue.

user415

2012-04-18 15:28

  ~0001274

Sorry I went to bed last night and did not reply to the last note

the time step actually went like this(copied from log)
Time = 1.00001
Time = 1.0000100000000001
Time = 1.0000150000000001
Time = 1.0000200000000001
Time = 1.0000250000000002
Time = 1.0000300000000002
.
.
.

my original timestep is set to be 5e-6 so it is not actually blowing up

henry

2012-04-18 15:34

manager   ~0001275

Various aspects of time handling have been improved in OpenFOAM-2.1.0 and 2.1.x and it is likely that you will not see this problem if you run OpenFOAM-2.1.x. In anycase if there is a problem we need a bug-report for OpenFOAM-2.1.x as it is this version to which any patches would be applied.

Issue History

Date Modified Username Field Change
2012-04-18 04:22 user415 New Issue
2012-04-18 04:22 user415 File Added: controlDict
2012-04-18 05:21 albertop Note Added: 0001264
2012-04-18 05:32 user415 Note Added: 0001265
2012-04-18 05:37 albertop Note Added: 0001266
2012-04-18 05:38 albertop Note Added: 0001267
2012-04-18 05:50 user415 Note Added: 0001268
2012-04-18 06:00 albertop Note Added: 0001269
2012-04-18 07:48 henry Note Added: 0001271
2012-04-18 07:48 henry Status new => closed
2012-04-18 07:48 henry Assigned To => henry
2012-04-18 07:48 henry Resolution open => fixed
2012-04-18 15:28 user415 Note Added: 0001274
2012-04-18 15:28 user415 Status closed => feedback
2012-04-18 15:28 user415 Resolution fixed => reopened
2012-04-18 15:34 henry Note Added: 0001275
2012-04-18 15:34 henry Status feedback => closed
2012-04-18 15:34 henry Resolution reopened => fixed