View Issue Details

IDProjectCategoryView StatusLast Update
0000485OpenFOAM[All Projects] Bugpublic2012-05-01 17:28
Reporteruser19Assigned Touser4 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000485: surfaceBooleanFeatures.C and surfaceSplitByTopology.C clear argList::validArgs instead of argList::validOptions
DescriptionCalling argList::validArgs.clear() doesn't make an awful lot of sense, since it's empty by default in the first place. So I assume what the original author actually wanted to do was to call argList::validOptions.clear() instead, as is done in surfaceSmooth.C. However, in the case of surfaceBooleanFeatures.C this would be clearly wrong, since it includes setRootCase.H and createTime.H, both of which AFAIK require a valid OpenFOAM case structure to be present.
TagsNo tags attached.

Activities

user4

2012-03-30 09:13

  ~0001186

Fixed in 86c19efb01106dab82aec8f78619ac21c8c5178f

Thanks for reporting.

user19

2012-03-30 09:34

  ~0001188

What about surfaceSplitByTopology.C?

user4

2012-05-01 17:28

  ~0001300

surfaceSplitByTopology: Fixed in a1af60e2da14c118b7f7749560a36101b208d81b.

Thanks.

Issue History

Date Modified Username Field Change
2012-03-26 15:25 user19 New Issue
2012-03-30 09:13 user4 Note Added: 0001186
2012-03-30 09:13 user4 Status new => resolved
2012-03-30 09:13 user4 Fixed in Version => 2.1.x
2012-03-30 09:13 user4 Resolution open => fixed
2012-03-30 09:13 user4 Assigned To => user4
2012-03-30 09:34 user19 Note Added: 0001188
2012-03-30 09:34 user19 Status resolved => feedback
2012-03-30 09:34 user19 Resolution fixed => reopened
2012-05-01 17:28 user4 Note Added: 0001300
2012-05-01 17:28 user4 Status feedback => resolved
2012-05-01 17:28 user4 Resolution reopened => fixed