View Issue Details

IDProjectCategoryView StatusLast Update
0004068OpenFOAMBugpublic2024-04-08 12:54
Reporternguyenhung97 Assigned Tohenry  
Status closedResolutionno change required 
PlatformGNU/LinuxOSCentOSOS Version7
Product Version11 
Summary0004068: functionEntry does not work in CentOS 7
DescriptionI tried to run the tutorials $(FOAM_TUTORIALS)/incompressibleFluid/hopperParticles and $(FOAM_TUTORIALS)/incompressibleFluid/pitzDaily but blockMesh and foamRun commands created "segmentation fault" bugs. However, when I commented the lines #includeModel and #includeFunc in the controlDict, everything worked fine although of course the desired #includeModel and #includeFunc were not run.

Additionally, I tried to foamCleanCase but it showed that the case diretory was not valid. I tested on Ubuntu 22.04.3 LTS on my pc and it worked just fine.

I compiled OpenFOAM-v11 in CentOS 7 with Intel oneAPI ver 2021.6.0 with the development toolset ver 7. The compilation was successful without any errors. On the same machine, I compiled OpenFOAM-v10 and it also worked fine so I guess there was some subtle bugs in OpenFOAM-v11.
Steps To Reproduce1. Compiled OpenFOAM-v11 on CentOS 7 with Intel oneAPI ver 2021.6.0 and the development toolset ver 7.
2. Run two tutorial cases as described above.
TagsNo tags attached.



2024-04-08 12:12



2024-04-08 12:54

manager   ~0013220

User support funding will be required to work directly on the users particular installation combination.

Issue History

Date Modified Username Field Change
2024-04-08 12:12 nguyenhung97 New Issue
2024-04-08 12:12 nguyenhung97 File Added: Screenshot 2023-03-12 173540.png
2024-04-08 12:12 nguyenhung97 File Added: Screenshot 2024-04-08 200716.png
2024-04-08 12:54 henry Assigned To => henry
2024-04-08 12:54 henry Status new => closed
2024-04-08 12:54 henry Resolution open => no change required
2024-04-08 12:54 henry Note Added: 0013220