View Issue Details

IDProjectCategoryView StatusLast Update
0004057OpenFOAMBugpublic2024-06-18 08:13
ReporterUlrich Assigned Tochris  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version22.04 LTS
Product Version11 
Summary0004057: ParaFoam does not start
DescriptionThe Ubuntu Linux is installed on WSL 2, Windows 10

OpenFOAM 11 is installed according to the following instruction:
https://openfoam.org/download/windows/

When launching paraFoam in OpenFOAM 11 environment in the pitzDailySteady test case no window opens but the following message appears:
qt.qpa.xcb: could not connect to display 172.24.192.1:0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.



I tried to change DISPLAY to "export DISPLAY=:0" but then a segmentation fault with the attached error message occours.

 
TagsNo tags attached.

Activities

Ulrich

2024-02-23 14:14

reporter  

paraFoam.zip (7,920 bytes)

Ulrich

2024-02-24 14:37

reporter   ~0013201

Today I installed the standard paraview with:
    sudo apt-get update
    sudo apt-get -y install paraview

With DISPLAY=:0 it opens without problems.

But with DISPLAY=172.24.192.1:0 as set by
echo "export DISPLAY=$(awk '/nameserver / {print $2; exit}' /etc/resolv.conf 2>/dev/null):0" >> ${HOME}/.bashrc
it again gives the following message:
    qt.qpa.xcb: could not connect to display 172.24.192.1:0
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

    Aborted

Setting display back to DISPLAY=:0 and loading openfoam environment with
source /opt/openfoam11/etc/bashrc
then starting paraview again gives the segmentation fault documented in the attached paraFoam.zip.

I've got the impression that something with the openfoam environment does not fit in my system.

blackk100

2024-03-26 01:34

reporter   ~0013217

Setting ParaView_GL=system or ParaView_GL="" fixes this on my install (OpenFOAM-11 in Ubuntu 22.04 on WSL2 Windows 11 23H2).
Seems to be due to an older fix due to a rendering bug in ParaView. The variable itself is defined in etc/config.sh/paraview (https://github.com/OpenFOAM/OpenFOAM-11/blob/71b07bb46985607e3b78e9404e8b5129989de411/etc/config.sh/paraview#L69).

Installing Mesa drivers (mesa-va-drivers) did not help.

chris

2024-06-18 08:13

manager   ~0013267

We have changed the packaging of OpenFOAM 11 and -dev on Ubuntu 24.04 and 22.04 to use the standard paraview package
https://openfoam.org/download/11-ubuntu/
https://openfoam.org/download/dev-ubuntu/

I think this should fix the problem.

We have also simplified the installation process on WSL 2
https://openfoam.org/download/windows/

Issue History

Date Modified Username Field Change
2024-02-23 14:14 Ulrich New Issue
2024-02-23 14:14 Ulrich File Added: paraFoam.zip
2024-02-24 14:37 Ulrich Note Added: 0013201
2024-03-26 01:34 blackk100 Note Added: 0013217
2024-06-18 08:13 chris Assigned To => chris
2024-06-18 08:13 chris Status new => resolved
2024-06-18 08:13 chris Resolution open => fixed
2024-06-18 08:13 chris Note Added: 0013267