View Issue Details

IDProjectCategoryView StatusLast Update
0000039OpenFOAM[All Projects] Bugpublic2010-10-07 18:04
Reporteruser19Assigned Touser4 
PriorityhighSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000039: Duplicate class Foam::regionProperties
DescriptionAbsolutely identical copies show up in

applications/solvers/heatTransfer/chtMultiRegionFoam/regionProperties/regionProperties.[CH]

and

src/turbulenceModels/compressible/RAS/derivedFvPatchFields/turbulentTemperatureCoupledBaffle/regionProperties.[CH]

Since chtMultiRegionFoam also links against libcompressibleRASModels this can (depending on the compiler/linker combination) lead to very strange run-time failures, such as failing dynamic_cast's.

As both implementations are identical, removing the one from chtMultiRegionFoam seems to be the simplest solution and also solves the problem for me.
TagsModelling, Solver

Activities

user4

2010-09-17 17:59

  ~0000041

Thanks.

Fixed in 98cc9ffd0d7a9b28c6d3f2e84b00cae36e1fd037

Issue History

Date Modified Username Field Change
2010-09-17 12:36 user19 New Issue
2010-09-17 13:09 user2 Assigned To => user4
2010-09-17 13:09 user2 Status new => assigned
2010-09-17 17:59 user4 Note Added: 0000041
2010-09-17 17:59 user4 Status assigned => resolved
2010-09-17 17:59 user4 Fixed in Version => 1.7.x
2010-09-17 17:59 user4 Resolution open => fixed
2010-10-07 18:04 user2 Tag Attached: Modelling
2010-10-07 18:04 user2 Tag Attached: Solver