View Issue Details

IDProjectCategoryView StatusLast Update
0003865OpenFOAMBugpublic2022-07-19 14:02
Reportercfd_cole Assigned Tohenry  
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSManjaro (ArchLinux)OS Version21.3.3
Product Version9 
Fixed in Version9 
Summary0003865: multiphaseEulerFoam produces IO Error with GCC 12
DescriptionSimilar to issue #0003856, but solution for that issue is not working.

Running the multiphaseEulerFoam/RAS/fluidisedBed tutorial, after successful blockMesh, setFields, and decomposePar, running the multiphaseEulerFoam results in the error:

error in IOstream "OSHA1stream.sinkFile_" for operation Ostream& operator<<(Ostream&, const word&)

file: OSHA1stream.sinkFile_ at line 0.

    From function virtual bool Foam::IOstream::check(const char*) const
    in file db/IOstreams/IOstreams/IOstream.C at line 96.

FOAM exiting

I've followed the fix per, but even with updating the "src/OpenFOAM/db/IOstreams/hashes/OSHA1stream.H" file, I still get the same error every time.

Steps To ReproduceRun the multiphaseEulerFoam/RAS/fluidisedBed tutorial with gcc 12.1.0, specifically at the point of using the multiphaseEulerFoam application.
TagsNo tags attached.



2022-07-16 23:54

manager   ~0012686

I am unable to reproduce this problem, all the tutorial cases run fine in OpenFOAM-9, 10 and dev when compiled with gcc-12.1.

Issue History

Date Modified Username Field Change
2022-07-16 23:04 cfd_cole New Issue
2022-07-16 23:54 henry Note Added: 0012686
2022-07-19 14:02 henry Assigned To => henry
2022-07-19 14:02 henry Status new => closed
2022-07-19 14:02 henry Resolution open => unable to reproduce
2022-07-19 14:02 henry Fixed in Version => 9