View Issue Details

IDProjectCategoryView StatusLast Update
0003784OpenFOAMBugpublic2022-01-16 13:31
ReportercgoessniAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSDebianOS Versionstable
Product Versiondev 
Fixed in Version 
Summary0003784: decomposePar does not work with engineTime for negative times
DescriptionWhenever a case with userTIme engine is decomposed, it would not work if the start time is negative

Time = -0.02CAD ******

Processor 0: field transfer
Selecting userTime engine


--> FOAM FATAL ERROR:
Cannot find file "points" in directory "polyMesh" in times "-180" down to constant

    From function virtual Foam::IOobject Foam::fileOperation::findInstance(const Foam::IOobject&, Foam::scalar, const Foam::word&) const
    in file global/fileOperations/fileOperation/fileOperation.C at line 865.

FOAM exiting

The line that I marked with ****** indicates that the time conversion is somehow not down. When the start time is positive, it would decompose the case, but still print the wrong time, e.g. if I change the start time to 540CAD in the kivaTest tutorial, it would still print

Time = 0.06CAD

but the time name in the processor directory is correct:

[clemens@acer: kivaTest] $ ll processor0/
total 8.0K
drwxr-xr-x 2 clemens clemens 4.0K Jan 15 09:18 540
drwxr-xr-x 3 clemens clemens 4.0K Jan 15 09:18 constant
Steps To ReproduceTry to decompose $FOAM_TUTORIALS/combustion/XiFoam/RAS/kivaTest
TagsNo tags attached.

Activities

henry

2022-01-15 21:17

manager   ~0012412

Try commit aab660450aae87b6276dcfa3ae105d32b5de7d7a

cgoessni

2022-01-16 13:16

reporter   ~0012413

The problem is gone with the above commit. Thanks!

Issue History

Date Modified Username Field Change
2022-01-15 08:18 cgoessni New Issue
2022-01-15 21:17 henry Note Added: 0012412
2022-01-16 13:16 cgoessni Note Added: 0012413
2022-01-16 13:31 henry Assigned To => henry
2022-01-16 13:31 henry Status new => resolved
2022-01-16 13:31 henry Resolution open => fixed