View Issue Details

IDProjectCategoryView StatusLast Update
0003782OpenFOAMBugpublic2022-01-14 15:07
ReportercgoessniAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Platformamd64OSCentOSOS Version7
Product Version9 
Fixed in Versiondev 
Summary0003782: mass change for closed volume simulation using XiEngineFoam
DescriptionIf I record the mass for each time step, the kivaTest tutorial shows that mass is lost/changed during the simulation. (adapted logSummary.H and logSummary.-180.dat attached for reference).

I did also some checks and it seems that the mass changes also with other compressible solvers using a dynamic mesh.
Steps To ReproduceAdd record of total mass to the logFile in XiEngineFoam and run the kivaTest tutorial
Additional InformationA quick check shows that this also happens with engineFoam.
TagsNo tags attached.

Activities

cgoessni

2022-01-14 09:52

reporter  

startSummary.H (411 bytes)
logSummary.-180.dat (88,511 bytes)

henry

2022-01-14 09:59

manager   ~0012390

Try using OpenFOAM-dev

cgoessni

2022-01-14 10:35

reporter   ~0012391

Mass seems to be perfectly conserved using OpenFOAM-dev. Any chance to find out the differences between -9 and -dev and extract a backport fix? Or was there too much change between these versions?

henry

2022-01-14 10:43

manager   ~0012393

Can you work on this yourself or provide maintenance funding?

henry

2022-01-14 11:13

manager   ~0012395

We have active projects w.r.t. mesh-motion, refinement/unrefinement, load-balancing etc. so there will be more changes is this area but the fundamental restructuring to support it is complete so you should work with OpenFOAM-dev if your work involves this functionality.

cgoessni

2022-01-14 11:26

reporter   ~0012396

Thanks for letting me know, that helps a lot.

I guess this issue can be closed then.

henry

2022-01-14 15:07

manager   ~0012409

Already fixed in OpenFOAM-dev

Issue History

Date Modified Username Field Change
2022-01-14 09:52 cgoessni New Issue
2022-01-14 09:52 cgoessni File Added: startSummary.H
2022-01-14 09:52 cgoessni File Added: logSummary.-180.dat
2022-01-14 09:59 henry Note Added: 0012390
2022-01-14 10:35 cgoessni Note Added: 0012391
2022-01-14 10:43 henry Note Added: 0012393
2022-01-14 11:13 henry Note Added: 0012395
2022-01-14 11:26 cgoessni Note Added: 0012396
2022-01-14 15:07 henry Assigned To => henry
2022-01-14 15:07 henry Status new => closed
2022-01-14 15:07 henry Resolution open => no change required
2022-01-14 15:07 henry Fixed in Version => dev
2022-01-14 15:07 henry Note Added: 0012409