View Issue Details

IDProjectCategoryView StatusLast Update
0003717OpenFOAMPatchpublic2021-08-25 12:02
ReportermboesiAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSOtherOS Version(please specify)
Product Version9 
Fixed in Version9 
Summary0003717: Dynamic compilation of TDACChemistryModel fails
DescriptionThe running the TDACChemistryModel fails when using thermo-physics not pre-defined in the chemistryModel. The issue is related to a missing symbol.
I've checked the problem and found out that the pre-processor instruction in the basicChemistryModelTemplate.C has a typo and, therefore, the standardChemistryModel and the chemistryReduction- and chemistryTabulationMethods are not compiled.
The instruction reads:
"#if ${method}CppTest == TDACChemistryModelCppTest" but should be "#if ${method}ChemistryModelCppTest == TDACChemistryModelCppTest".

I've attached a corrected version of the file and a test case based on the DLR_A_LTS case.
Steps To ReproduceSelect a non
TagsNo tags attached.

Activities

mboesi

2021-08-24 17:50

reporter  

DLR_A_LTSTest.tar.xz (21,916 bytes)
basicChemistryModelTemplate.C (6,148 bytes)

henry

2021-08-25 11:25

manager   ~0012163

I can't reproduce the problem with the case you have provided, I get a string of errors from the thermo relating to incorrect input:

[0]
[0]
[0] --> FOAM FATAL IO ERROR:
[0] keyword muCoeffs<8> is undefined in dictionary "/home/dm2/henry/Downloads/DLR_A_LTSTest/constant/thermophysicalProperties/H2/transport"
[0]
[0] file: /home/dm2/henry/Downloads/DLR_A_LTSTest/constant/thermophysicalProperties/H2/transport from line 809 to line 810.
[0]
[0] From function const Foam::entry& Foam::dictionary::lookupEntry(const Foam::word&, bool, bool) const
[0] in file db/dictionary/dictionary.C at line 811.
.
.
.

henry

2021-08-25 12:02

manager   ~0012165

Resolved in OpenFOAM-9 by commit 7b57b4747f7583bad0fed179581a191f542709e4
Resolved in OpenFOAM-dev by commit 9b8aa48a7ed3d1f5e9f61c83c41d8b0e828a6af8

Issue History

Date Modified Username Field Change
2021-08-24 17:50 mboesi New Issue
2021-08-24 17:50 mboesi File Added: DLR_A_LTSTest.tar.xz
2021-08-24 17:50 mboesi File Added: basicChemistryModelTemplate.C
2021-08-25 11:25 henry Note Added: 0012163
2021-08-25 12:02 henry Assigned To => henry
2021-08-25 12:02 henry Status new => resolved
2021-08-25 12:02 henry Resolution open => fixed
2021-08-25 12:02 henry Fixed in Version => 9
2021-08-25 12:02 henry Note Added: 0012165