View Issue Details

IDProjectCategoryView StatusLast Update
0003711OpenFOAMBugpublic2021-08-16 11:26
ReporterjheylmunAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Version9 
Fixed in Version9 
Summary0003711: heheuPsiThermo does not update Cp and Cv
Descriptionthe heheuPsiThermo does not update Cp and Cv values which results is 0 for both fields since they are only calculated in the correct function
Steps To Reproduceadd
functions
{
    CpCv
    {
        type writeObjects;
        libs ("libutilityFunctionObjects.so");

        objects (Cp Cv);
    }
}
to OpenFOAM-9/tutorials/combustion/XiFoam/RAS/moriyoshiHomogeneous//controlDict and run case
TagsNo tags attached.

Activities

henry

2021-08-16 11:26

manager   ~0012150

Thanks for the bug-report
Resolved in OpenFOAM-9 by commit 0a36666bfadb6595330b575b3a5747cbe631cfdb
Resolved in OpenFOAM-dev by 64e94cfa6654dcb7dd0f8f89954040c13adc231a

Issue History

Date Modified Username Field Change
2021-08-13 19:53 jheylmun New Issue
2021-08-16 11:26 henry Assigned To => henry
2021-08-16 11:26 henry Status new => resolved
2021-08-16 11:26 henry Resolution open => fixed
2021-08-16 11:26 henry Fixed in Version => 9
2021-08-16 11:26 henry Note Added: 0012150