View Issue Details

IDProjectCategoryView StatusLast Update
0003698OpenFOAMBugpublic2021-07-26 15:12
Reporterhypercorei11Assigned Tochris 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version9 
Fixed in Version 
Summary0003698: FoamCleanPolyMesh command not found.
DescriptionfoamCleanPolyMesh command not found.
Steps To ReproduceKubuntu v21
Fresh install of Ubuntu version 21 and openFoam version 9.
Issue terminal command as defined in the summary and receive a command not found response.

Inspected the openFoam directories and found that the binary for that command is not present.
I downloaded the application again and reinstalled and found the same condition.

Additional Information
MyFix: copy the binary from an openFoam version 8 to the openfoam version 9 directory.
TagsNo tags attached.

Activities

henry

2021-07-26 08:38

manager   ~0012102

Last edited: 2021-07-26 08:41

View 2 revisions

foamCleanPolyMesh is not a binary it is a script which has been superseded by foamCleanCase

If you specifically want to remove only the polyMesh directory you can now use 'rm -r' because the polyMesh directory contains only generated files.

chris

2021-07-26 09:09

manager   ~0012103

It is also not generally necessary to delete the contents of the polyMesh directory other than to "clean" a case - which foamCleanCase does.
That is because when blockMesh is run, it deletes the contents of the polyMesh directory itself, prior to writing the mesh.
Whether the mesh is generated with blockMesh itself, or snappyHexMesh, it always begins with running blockMesh which deletes the contents.

hypercorei11

2021-07-26 14:14

reporter   ~0012107

While I stand corrected in referring to the source of the command as a binary, I cannot help wondering why if you removed the command from this release you didn't reflect the change in the openFoam version 9 user guide. Which I consulted before submitting this bug report. Sometimes doing something halfway is worse than not doing it at all.

Might I suggest that before responding to users and such a condescending way that you've read your in documentation.

administrator

2021-07-26 15:10

administrator   ~0012109

Responses to issues are not solely for the reporter's benefit but for other members of the public who might come across them at any time in the future.
The point made about foamCleanPolyMesh being a script was to prevent confusion generally about portability.
We don't want (other) members of the public expecting to copy a binary file from one version to another and expecting it to run.
My comments were also to inform the general public why foamCleanPolyMesh is redundant.
We don't want it to be part of a workflow when it is not needed.
The update to the user guide slipped through the net, but it is being corrected.

Issue History

Date Modified Username Field Change
2021-07-26 02:25 hypercorei11 New Issue
2021-07-26 08:38 henry Note Added: 0012102
2021-07-26 08:41 henry Note Edited: 0012102 View Revisions
2021-07-26 09:09 chris Note Added: 0012103
2021-07-26 14:14 hypercorei11 Note Added: 0012107
2021-07-26 15:10 administrator Note Added: 0012109
2021-07-26 15:12 chris Assigned To => chris
2021-07-26 15:12 chris Status new => closed
2021-07-26 15:12 chris Resolution open => fixed