View Issue Details

IDProjectCategoryView StatusLast Update
0003676OpenFOAMBugpublic2021-05-19 17:11
ReporterMPR015Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Platformx86_64OSCentOSOS Version7.7.1908 (Core)
Product Version8 
Fixed in Version 
Summary0003676: FOAM FATAL ERROR upon executing solver post processing for sprayFoam -postProcess -func [function]
DescriptionExecuting sprayFoam -postProcess -func [function] produces a FOAM FATAL ERROR of general form:

Problem adding watch 4 to file "[dirPath]/aachenBomb/constant/chemistryProperties"

    From function bool Foam::fileMonitorWatcher::addWatch(Foam::label, const Foam::fileName&)
    in file fileMonitor.C at line 258.

FOAM aborting
Steps To Reproducecd [tutorialDirPath]/aachenBomb/
./Allrun
sprayFoam -postProcess -func CourantNo
Additional InformationCouranNo used as an example - the same error results even after putting "banana" there.
TagsNo tags attached.

Activities

henry

2021-05-18 07:40

manager   ~0012028

I am unable to reproduce this error. I ran the aachenBomb and

./Allrun
sprayFoam -postProcess -func CourantNo

and get the correct behaviour and the Co fields in the time directories.

MPR015

2021-05-18 10:03

reporter   ~0012031

Hi,

The postProc works on a local (Windows Subsystem for Linux) installation (ubuntu).

We'll check the Centos source compiled version and get back.

Cheers!

peksa

2021-05-19 12:30

reporter   ~0012035

I can provide a bit more information on MPR015 report:

- This issue appears with Centos 7 in HPC environment.
- I have not been able to reproduce the problem on Ubuntu 18.04
- I have updated and recompiled both OF-8 and OF-dev versions with no issues in compilation.
- OF-dev does not produce this error behavior.
- OF-7 does not produce this error either.

- error does not appear if I force a time step. In other words, "sprayFoam -postProcess -time 5e-5" works. However, any time sequence fails and results in an error described in earlier messages. Typically the first time instance works, while the second, and later ones produce the error.

- This error seems to be related to combustion class solvers. I'm unable to produce this error with e.g. rhoPimpleFoam, but I can reproduce with reactingFoam DLR tutorial.

- I was suspecting that chemkinToFoam could be a culprit and remade the chemistryProperties file by including the reactions block as plain text there. No change, error remained.

Could this be related to file system / OS in some way? I'm open to test ideas. This

henry

2021-05-19 12:53

manager   ~0012036

I have no means to reproduce this error and have never installed or used Centos. I have no idea why Centos should be causing problems but maybe it would be good to upgrade to a more recent GNU/Linux distribution.

Issue History

Date Modified Username Field Change
2021-05-18 06:27 MPR015 New Issue
2021-05-18 07:40 henry Note Added: 0012028
2021-05-18 10:03 MPR015 Note Added: 0012031
2021-05-19 12:30 peksa Note Added: 0012035
2021-05-19 12:53 henry Note Added: 0012036
2021-05-19 17:11 henry Assigned To => henry
2021-05-19 17:11 henry Status new => closed
2021-05-19 17:11 henry Resolution open => unable to reproduce