View Issue Details

IDProjectCategoryView StatusLast Update
0000367OpenFOAM[All Projects] Bugpublic2011-12-21 09:52
ReporteralbertopAssigned Tohenry 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSopenSUSEOS Version12.1
Product Version 
Fixed in Version 
Summary0000367: Unused kineticTheory code in multiphaseEulerFoam
DescriptionThe multiphaseEulerFoam code contains the directory "kineticTheory", but the code contained in it is not used in the solver.

Note that the code is built by the Allwmake script too.
TagsNo tags attached.

Activities

henry

2011-12-21 07:54

manager   ~0000856

Indeed, this is a very preliminary release of this solver that includes the basic functionality for Euler multiphase with VoF option but does not yet include either compressibility effects or knietic theory. These parts are in progress and some of the relevant code is present but commented out for this release. If this is causing confusion and the solver is not useful to people in the current state we can remove it from the release.

albertop

2011-12-21 08:44

reporter   ~0000859

Thank you for the explanation. I don't think it's confusing, and the code is very interesting. I thought the kinetic theory module was orphaned, and remained there because of the derivation from twoPhaseEulerFoam.

Issue History

Date Modified Username Field Change
2011-12-20 23:53 albertop New Issue
2011-12-21 07:54 henry Note Added: 0000856
2011-12-21 08:44 albertop Note Added: 0000859
2011-12-21 09:52 henry Status new => resolved
2011-12-21 09:52 henry Resolution open => fixed
2011-12-21 09:52 henry Assigned To => henry