View Issue Details

IDProjectCategoryView StatusLast Update
0003668OpenFOAMContributionpublic2021-05-04 14:38
Reportersjohn2Assigned Tohenry 
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionsuspended 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Versiondev 
Fixed in Version 
Summary0003668: Addition of a new Heat transfer Model in multiPhaseEulerFoam solver
DescriptionI would like to submit a new heat transfer model Alexandrov 1967. The references are listed in the .H files

The files can be found here:

https://github.com/stanabng2501/dev-10-16-2020-particle-gravity/tree/main/applications/solvers/multiphase/multiphaseEulerFoam/interfacialModels/heatTransferModels/Alesksandrov

other files to be changed are:
https://github.com/stanabng2501/dev-10-16-2020-particle-gravity/tree/main/applications/solvers/multiphase/multiphaseEulerFoam/interfacialModels/Make

There is a error in the definition of Jakob Number in Lucas 2015. It has been corrected in the code.
TagsNo tags attached.

Activities

henry

2021-04-28 11:47

manager   ~0012005

What is the purpose if this particular model?
For what cases is it better than the models already provided and maintaining in OpenFOAM?
Can or should it replace any of the existing models in OpenFOAM?

sjohn2

2021-04-28 21:12

reporter   ~0012006

If you check the paper from Liao Lucas 2015 (referenced in the .H file) they recommend this model for calculating the heat transfer coefficient for phase change in case of evaporating flows. They say it is better than the Ranz Marshall model currently coded in OpenFoam.

henry

2021-04-28 21:52

manager   ~0012007

Have you run any cases which demonstrates this? Can you provide some comparisons from your runs?

sjohn2

2021-04-28 22:53

reporter   ~0012008

I have run a few cases and definitely Ranz Marshall model over predicts the mass transfer between phases. However I need to run many more cases to validate my findings. This submission is based on the research findings of Liao & Lucas 2015, who have been using this model for 5 years. I can come up with a comparison paper within 3 months.

oertel59

2021-05-03 16:40

reporter   ~0012013

For your own cases, can you report the min/max/avg of the Nusselt numbers using RanzMarshall and Aleksandrov? Is the order of magnitude roughly the same?

sjohn2

2021-05-03 19:30

reporter   ~0012014

I get different Nusselts number for both cases after solution is converged. Both cases have same diameter models.

Ranz Marshall Nu min = 2.46007461265 Nu mean = 17.1137987549 Nu max = 30.5396340562
Alesksandrov Nu min = 0.901877868633 Nu mean = 8.49950221123 Nu max = 20.4025354199

I am using a solver for evaporation phase change which can be found at my github account:
https://github.com/stanabng2501/dev-10-16-2020-particle-gravity/tree/main/applications/solvers/multiphase/multiphaseEulerFoam/phaseSystems/PhaseSystems/EvaporationPhaseChangePhaseSystem

My case setup can be found here:
https://drive.google.com/drive/u/0/folders/1Axynl0XLZvBSwnLt_VP9AuggNlZHmcIc

oertel59

2021-05-04 06:05

reporter   ~0012015

Ok, I tested with a single cell case provided in test/multiphase/multiphaseEulerFoam/thermal/waterEvaporation and since there is no relative velocity between the phases, the Pe contribution is zero while the Ja contribution is small leading to overall Nu numbers that are orders of magnitude lower than with RanzMarshall. This is worries me. For tutorials/multiphase/multiphaseEulerFoam/RAS/wallBoiling the Pe contribution is meaningful as there is relative velocity, but the Pe number contribution is almost negligible again.

    Info<< "Ja contribution, min, max = "
        << (12*sqr(Ja/pi))()
          .weightedAverage(pair_.mesh().V()).value()
        << ' ' << min(12*sqr(Ja/pi)).value()
        << ' ' << max(12*sqr(Ja/pi)).value()
        << endl;

    Info<< "Pe contribution, min, max = "
        << (Pe/(3*pi))()
          .weightedAverage(pair_.mesh().V()).value()
        << ' ' << min(Pe/(3*pi)).value()
        << ' ' << max(Pe/(3*pi)).value()
        << endl;

gives me something like this:

Tsub, min, max = 8.7160689 -2.01325857 19.1193618
Ja contribution, min, max = 1.02503824 3.35509475e-09 4.25998342
Pe contribution, min, max = 108.247141 16.9233651 2997.17637
Nu, min, max = 10.3870033 4.11942249 54.7469294

Can you please explain this model characteristic?

oertel59

2021-05-04 06:33

reporter   ~0012016

The issue for the test case in particular, i.e. with sitting vapor bubbles, RanzMarshall will always lead to a Nusselt number of 2. The model suggested by you causes Tsub to persist in this transient case and leads to something like

Tsub, min, max = -26.75016724 -26.75016724 -26.75016724
Ja contribution, min, max = 3.52159648e-10 3.52159648e-10 3.52159648e-10
Pe contribution, min, max = 0 0 0
Nu, min, max = 1.876591719e-05 1.876591719e-05 1.876591719e-05

oertel59

2021-05-04 06:45

reporter   ~0012017

Have you checked the original reference for this model also or did you simply take it from Liao & Lucas 2015? In case you have checked the original, is there maybe some other limiting term in case of conduction heat transfer only? Or is it just the Jacob contribution? Apparently, it doesn't do the job for this limit.

sjohn2

2021-05-04 08:28

reporter   ~0012018

I still have to get hold of the original reference and check the limitations of the model.
I did take the model from Liao & Lucas 2015. It certainly seems to be unsuitable for cases that are typical in multi phase tutorials and I am testing cases with pressure driven phase change.
I will update in a few months once I have exhaustively tested more cases.

oertel59

2021-05-04 12:18

reporter   ~0012019

I suggest you contact the corresponding author of the paper to figure out the origin. Until then, I would say we close this issue.

henry

2021-05-04 14:38

manager   ~0012021

Please contact the OpenFOAM Foundation to discuss this contribution and sign the OpenFOAM Foundation Contributor Agreement.

https://openfoam.org/dev/how-to-contribute/

Issue History

Date Modified Username Field Change
2021-04-27 20:57 sjohn2 New Issue
2021-04-28 11:47 henry Note Added: 0012005
2021-04-28 21:12 sjohn2 Note Added: 0012006
2021-04-28 21:52 henry Note Added: 0012007
2021-04-28 22:53 sjohn2 Note Added: 0012008
2021-05-03 16:40 oertel59 Note Added: 0012013
2021-05-03 19:30 sjohn2 Note Added: 0012014
2021-05-04 06:05 oertel59 Note Added: 0012015
2021-05-04 06:33 oertel59 Note Added: 0012016
2021-05-04 06:45 oertel59 Note Added: 0012017
2021-05-04 08:28 sjohn2 Note Added: 0012018
2021-05-04 12:18 oertel59 Note Added: 0012019
2021-05-04 14:38 henry Assigned To => henry
2021-05-04 14:38 henry Status new => closed
2021-05-04 14:38 henry Resolution open => suspended
2021-05-04 14:38 henry Note Added: 0012021