View Issue Details

IDProjectCategoryView StatusLast Update
0003663OpenFOAMFeaturepublic2021-04-15 13:40
Reportermichael.mueller-wrdAssigned Tohenry 
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionsuspended 
PlatformUnixOScentOSOS Version(please specify)
Product Version8 
Fixed in Version 
Summary0003663: check for incomplete definition of layers at mappedWall patches of interfaces between separate regions
DescriptionFor chtMultiRegionFoam solver at interfaces between separate regions, one may use thicknessLayers / kappaLayers to account for additional thermal resistances.
This has to be defined in the corresponding BC files of each region, say 0/<regionA>/T, 0/<regionB>/T, for the compressible::turbulentTemperatureCoupledBaffleMixed patches called regionA_to_regionB and regionB_to_regionA

In case, the definition of thermal resistances is only included in one of the interface regions, the solver runs regardless and produces evidently wrong (or at least unwanted) results.

Is it possible to catch this kind of incomplete definition of the case setup during solver run and abort with FOAM ERROR?
I think, this would be a very helpful feature because there is probably no application which requires the layers at an interface but only at one of the adjacent regions.
Steps To Reproducetake one of chtMultiRegionFoam tutorials, e.g. for "coolingSphere".
First run, define thermal layer at interface patch of solid region only:
0/solid/T:
...
        thicknessLayers ( 0.001 );
        kappaLayers ( 1 );
...

Second run, add thermal layer at interface patch of fluid region:
0/fluid/T:
...
        thicknessLayers ( 0.001 );
        kappaLayers ( 1 );
...
TagsNo tags attached.

Activities

henry

2021-04-14 18:47

manager   ~0011996

It should be possible to do this but non-trivial. Can you provide a patch or funding?

henry

2021-04-15 13:40

manager   ~0012000

Pending funding.

Issue History

Date Modified Username Field Change
2021-04-14 18:20 michael.mueller-wrd New Issue
2021-04-14 18:46 henry Priority normal => none
2021-04-14 18:46 henry Severity feature => minor
2021-04-14 18:46 henry Category Bug => Feature
2021-04-14 18:47 henry Note Added: 0011996
2021-04-15 13:40 henry Assigned To => henry
2021-04-15 13:40 henry Status new => closed
2021-04-15 13:40 henry Resolution open => suspended
2021-04-15 13:40 henry Note Added: 0012000