View Issue Details

IDProjectCategoryView StatusLast Update
0003649OpenFOAMPatchpublic2021-03-29 11:25
ReporterYang LuAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Version 
Fixed in Version 
Summary0003649: Particle tracking across AMI patches is only currently supported for cases where the AMI patches reside on a single processor
DescriptionParticle tracking across AMI patches is only currently supported for cases where the AMI patches reside on a single processor.
When I run a DPM solution I found that the particle tracking can not be run parallel when the cyclic AMI patch boundary was set.
Here is some report information. I found in the issue community there is someone meets the same problem. However, it does not show the details of the solution.
Constructing kinematicCloud kinematicCloud
[2]
[2]
[2] --> FOAM FATAL ERROR:
[2] Particle tracking across AMI patches is only currently supported for cases where the AMI patches reside on a single processor
[2] [3]
[3]
[3] --> FOAM FATAL ERROR:
[3] Particle tracking across AMI patches is only currently supported for cases where the AMI patches reside on a single processor
[3]
[3] From function void Foam::Cloud<ParticleType>::checkPatches() const [with ParticleType = Foam::CollidingParcel<Foam::KinematicParcel<Foam::particle>
TagsNo tags attached.

Activities

henry

2021-03-29 10:13

manager   ~0011954

> Particle tracking across AMI patches is only currently supported for cases where the AMI patches reside on a single processor

That is correct. Would you like to fund further development of the AMI functionality to remove this restriction?

Yang Lu

2021-03-29 11:16

reporter   ~0011955

Thanks for your timely reply. Actually, I want to know how to solve this problem. Because I found someone state they found the solution in this issue tracking community. I think it does not need more further development than can remove this restriction.

Issue History

Date Modified Username Field Change
2021-03-29 09:57 Yang Lu New Issue
2021-03-29 10:13 henry Note Added: 0011954
2021-03-29 11:16 Yang Lu Note Added: 0011955
2021-03-29 11:25 henry Assigned To => henry
2021-03-29 11:25 henry Status new => closed
2021-03-29 11:25 henry Resolution open => no change required